Skip to Content
avatar image
Former Member

IDOC Receiver channel 7.31 Java stack error-Connection factory name for channel is null


Hi,


   Its related to re-pointing from QA to Regression environment.

   We have IDOC_AAE receiver channel configured to QA environment and its working good. We want to reroute QA to RE . At this point  am getting this error.


Transmitting the message to endpoint <local> using connection JMS_http://sap.com/xi/XI/System failed, due to: com.sap.aii.af.idoc.exception.IDOCAdapterException: IDoc: Connection factory name for channel IDoc_RCV_XXXX is null



created default destination of RE environment under QA (NWA-> Destinations) . Connectivity is working fine as ping test is successful.

under OutboudRa new default destination and every configuration is completed (along with JCA Connection factory settings)with respect to QA default destination. New IDOC channel created with RE1 default destination.Now when am trying to connect ECC system, it throwing  connection factory name for channel is null.



  Is there any other changes did I miss? Does anyone have any idea on root cause of this issue? Please throw some light a bit earlier on this issue.


Aman

 

IDOC_receiver.png (12.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Oct 16, 2015 at 04:58 PM

    Hi

    Please check this blog.

    Regards

    Osman

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 16, 2015 at 06:14 PM

    The note which provided under that was for different error. And others discussing mostly InboundRa. Am having issue with Outbound Ra. Can any one suggest the solution for this

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      If you think there's some issue with the outboundRA, then could you please check once your JCA Connection Factory Details:

      NWA->Configuration->Infrastructure->Application Resources:

      Under ResourceName: outboundRA -> select one with Resource Type as JCA Resource

      Below you'll be able to see your receiver comm. channel under the Related JCA Conn. Factories tab

      Select your comm. channel and check the JCA Conn. Factory Details. Under Configuration Properties your target destination must be maintained.

      Also, check the outboudRA (Resource Adapter Type), setting should be as below:

  • Oct 19, 2015 at 08:40 AM

    Hello Kanth,

    Refer the below links

    iDoc_AAE Receiver Channel Error | SCN

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 24, 2015 at 01:47 AM

    Closing the issue.

      Issue got resolved by system refresh and updating properties under

    outboundRA.

    Add comment
    10|10000 characters needed characters exceeded