Skip to Content

IDM 8.0 and GRC integration - AC Validation not executed

Hello Experts,


Anyone have successfully integrated IDM 8.0 and GRC10?

I have performed initial load from one ABAP system

Configured VDS to GRC template (Web services were activated) and tested successfully.

then, ran GRC commons and centralized scenario load jobs.

GRC10 repository type has below validate tasks (no custom changes done in grc10 package)

Issue 1: UI is not working and we have raised an Incident with SAP already. So I tried to assign a privilege to user using a job. I see no AC Validation task triggered (nothing in job log or provisioning queue). Hence there was nothing in VDS side too. I checked the role in database and was in pending status (MCEXECSTATE as 512). After sometime, privs are in failed status (MCEXECSTATE as 4)

Is it a known issue for 8.0? Not sure why AC validation task is getting triggered. Anything else I should check?

The issue seems to be closely related to below note however it is valid for 7.2 SP9 and I can see WAIT_TASKID and WAIT_AUDITID in IDS schema.

1994592 - GRC 10.0 PF V2: Issues with execution of AC Validation due to missing attributes

Issue 2: I see AC_Validation_Add process as type "Add Member Process". Is it correct? I was in assumption this should be "Validate add process"

If I change Validate add to some other task e.g. AC_Validation_Risk_Analysis_Only_Add, I couldn't select back to AC_Validation_Add.

Kind regards,


Capture.PNG (11.3 kB)
Capture.PNG (17.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Nov 25, 2015 at 01:13 PM


    Anyone from SAP can confirm if this is an issue?

    We have set up new IDM 8.0 system again and tried. Still the same issue.

    1) VDS config working. (I was able to search the applications connected to GRC also other webservices are activated)

    2) Ran GRC loads (common and centralized provisioning).

    3) Assign priv in UI - (Goes to Waiting for few mins and then Failed after sometime. No tasks executed in job log)

    Anyone successfully integrated GRC and IDM 8.0 or faced this issue?

    Any advise would be helpful and appreciated.

    Kind regards,


    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Jai,

      did you try tracing your user? Usually when the workflow stops in the PrepareACRequest Java Code you can't see a log but if you trace, you'll see soemthing like !OnErrorTrigger or something like that.

      Then, you defined your validation tasks on the repository, but check that the privileges have inherited the tasks and that they have the correct rep defined as the validation repository


Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.