Skip to Content
avatar image
Former Member

Unable to register the iOS device to SMP server with MAFLogon?

Hi All,

Im unable to register the device to SMP server using the MAFLogon .

ERRor in Console:

2015-10-16 13:12:47.888 mAssetTag_Mars[5950:262353] ER:Registration failed with error: Error Domain=HTTPDomainError Code=404 "RegistrationFailed" UserInfo={NSLocalizedDescription=RegistrationFailed}

2015-10-16 13:12:47.889 mAssetTag_Mars[5950:262353] ER:Registration failed

2015-10-16 13:12:47.890 mAssetTag_Mars[5950:262353] ER:-[MAFLogonUIViewManager presentError:] Error Domain=MAFLogonCoreErrorDomain Code=3 "Could not connect to the server. Consult with the administrator." UserInfo={NSUnderlyingError=0x7b737090 {Error Domain=HTTPDomainError Code=404 "RegistrationFailed" UserInfo={NSLocalizedDescription=RegistrationFailed}}, NSLocalizedDescription=Could not connect to the server. Consult with the administrator.}

2015-10-16 13:12:47.915 mAssetTag_Mars[5950:262353] ER:Error: Could not connect to the server. Consult with the administrator.


Configuration Details:

SMP : SMP3.0 sp10,

Xcode:7,iOS 9

On Boarding : Using MAF Logon.

I am not sure, Where i am missing, So Please can any one help me out.

Thanks.

Praveen

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 16, 2015 at 08:18 AM

    What is SMP server version?

    Did you try on-boarding using REST client? Register the Application ID

    Can you share screenshot of application settings in Admin cockpit?Is that iOS device within same network as SMP server?

    Regards,

    JK

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 16, 2015 at 10:16 AM

    Hi Praveen,

    Double check the application connection details you provided in the app - appid, smpprotocol (http), server port (8080).

    Provide the app configuration details/screenshots from SMP cockpit.

    Regards, Midhun

    SAP Technology RIG

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 21, 2015 at 04:34 AM

    Hi Midhun/Jitendra,

    I can register the device when I'm using the SP7 and iOS 8 .But when I'm trying to register the device using the SP 7 and iOS 9 I'm getting the below error.

    But when I'm trying to register with SP 10 and iOS 9/ iOS  8 I'm getting the below error.

    2015-10-16 13:12:47.888 mAssetTag_Mars[5950:262353] ER:Registration failed with error: Error Domain=HTTPDomainError Code=404 "RegistrationFailed" UserInfo={NSLocalizedDescription=RegistrationFailed}

    2015-10-16 13:12:47.889 mAssetTag_Mars[5950:262353] ER:Registration failed

    2015-10-16 13:12:47.890 mAssetTag_Mars[5950:262353] ER:-[MAFLogonUIViewManager presentError:] Error Domain=MAFLogonCoreErrorDomain Code=3 "Could not connect to the server. Consult with the administrator." UserInfo={NSUnderlyingError=0x7b737090 {Error Domain=HTTPDomainError Code=404 "RegistrationFailed" UserInfo={NSLocalizedDescription=RegistrationFailed}}, NSLocalizedDescription=Could not connect to the server. Consult with the administrator.}

    2015-10-16 13:12:47.915 mAssetTag_Mars[5950:262353] ER:Error: Could not connect to the server. Consult with the administrator.


    Please help me.


    Thanks,

    Praveen.



    Add comment
    10|10000 characters needed characters exceeded