Skip to Content

FILTER option not working in FromSAP pass

Hi all,

I am reading user lock status from SAP by reading table USR02 into temp. table (FromPass). In ToIdentityStore Pass I then filter the user data with SELECT FROM temp.table WHERE ustyp = 'A' AND uflag = '128'. That's working fine. However, I was wondering if I could reduce the amount of read data from SAP using the FILTER option as outlined in note 1398976.

However, I don't get this working... I started with ustyp = 'A' (only dialog users):

RETURN_EMPTY_VALUES    false

ENTRYTYPE    TABLE

TABLE    USR02

COLUMNS    BNAME|USTYP|UFLAG|MANDT

NAMEFIELD    BNAME

jco.client.ashost    %$rep.JCO_CLIENT_ASHOST%

jco.client.sysnr    %$rep.JCO_CLIENT_SYSNR%

jco.client.user    %$rep.JCO_CLIENT_USER%

jco.client.client    %$rep.JCO_CLIENT_CLIENT%

jco.client.passwd    %$rep.JCO_CLIENT_PASSWD%

jco.client.lang    %$rep.JCO_CLIENT_LANG%

jco.client.group    %$rep.JCO_CLIENT_GROUP%

jco.client.gwhost    %$rep.JCO_CLIENT_GWHOST%

jco.client.gwserv    %$rep.JCO_CLIENT_GWSERV%

jco.client.mshost    %$rep.JCO_CLIENT_MSHOST%

jco.client.r3name    %$rep.JCO_CLIENT_R3NAME%

jco.client.snc_lib    %$rep.JCO_CLIENT_SNC_LIB%

jco.client.snc_mode    %$rep.JCO_CLIENT_SNC_MODE%

jco.client.snc_myname    %$rep.JCO_CLIENT_SNC_MYNAME%

jco.client.snc_partnername    %$rep.JCO_CLIENT_SNC_PARTNERNAME%

jco.client.snc_qop    %$rep.JCO_CLIENT_SNC_QOP%

CUA_MASTER    %$rep.CUA_MASTER%

FILTER    SELECTION_EXP:0/PARAMETER=LOGONDATA

FILTER1    SELECTION_EXP:0/FIELD=USTYP

FILTER2    SELECTION_EXP:0/OPTION=EQ

FILTER3    SELECTION_EXP:0/LOW=A

  

The job reads all users (163) in DEV wheras only 125 are dialog users. Why' its not working?

The second question is: as PARAMETER and fields I can only specify those that are referenced in BAPI_USER_GET_DETAIL (e.g. LOGONDATA). But in the structure is no corresponding field for UFLAG. So, is it possible to use this field in the FILTER option in any way?

Thanks

RP

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 16, 2015 at 06:19 AM

    Hi Richard,

    AFAIK, we cannot use filter option for reading data from tables.

    http://scn.sap.com/thread/3387959

    Not sure if this functionality added in recent version.

    Kind regards,

    Jaisuryan

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Richard,

      If you will go through the thread link shared by Jaisuryan  http://scn.sap.com/thread/3387959

      Christopher Leonard (from SAP IDM Support) already posted that "unfortunately with the SAP connector a filter on the read Table is not implemented which is why the filter options did not work".

      This is the reason, Read data FromSAP is not working, when you are applying filter.

      Regards,

      C Kumar

      FromSAP.JPG (34.1 kB)