Skip to Content
avatar image
Former Member

IdM 8.0 No available objects when adding an event process to an attribute

Hi,

I am trying to add an event process to an attribute but when I choose the selection button (... button) in the Event Processes tab the list returns no available objects.

I have created a process in a customer specific package and made the process public as instructed in the documentation Defining Event Processes for an Identity Store Attribute - SAP Identity Management Configuration Guide - SAP Library .

Is anyone else experiencing this issue, or can anyone offer any advice on something I might have missed?

Many thanks,

Pat

Version information:

IdM 8.0 SP1

Database Version: 8.0.1-ORA-2015-09-24

Database Schema Version: 1601

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 16, 2015 at 03:55 AM

    Hello Patrick,

    I am facing similar issue as well but in SAP provided package itself.

    When I click on ... button to add other process for Validate Add, I get only one task displayed. As you can see there are 6 public tasks available in the package.

    Kind regards,

    Jai

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Jannis Rondorf

      Thanks guys for the prompt assistance and advice.

      As you say I hadn't classified the process on the process properties tab and as such it didn't appear as one of the available objects for the event process.  I had overlooked the part where it clearly states  this in the configuration guide link that I posted above.

      "○ For the Add a process operation, you can only define a process of type Add Attribute Process.

      ○ For the Modify a process operation, you can only define a process of type Modify Attribute Process.

      For the Delete a process operation, you can only define a process of type Delete Attribute Process."

      Cheers!

      Pat