Skip to Content
avatar image
Former Member

Error while viewing CR on SAP BOE: The viewer could not process an event. Error in File xxx.rpt: The table could not be found. [] ---- Error code:0 [CRWEB00000119]

Hi all.

I have the following issue: I created a set of 23 CR reports in a QA environment which have worked smoothly. Then I promoted them to a PROD environment, but while I'm trying to view them on demand, I get the following error:

The viewer could not process an event. Error in File xxx.rpt: The table could not be found. []  ---- Error code:0 [CRWEB00000119]

It happens to any of the 23 promoted reports

All these reports are based on Oracle tables (and CR Commands) which I access via an ODBC connection

I've learned from the QA implementation, that both versions of Oracle Client (32 and 64 bits) must be installed in the BOE server (or servers if your BOE works as a Cluster )  and that, in the Path Environment Variable, the install path that must come first is the 32 bits version and then the 64 bits version, which I did in my BOE PROD Cluster. I created TNSNAMES.ORA and SQLNET.ORA files on each server, with the same entries as the original files in the QA cluster.

Besides, I generated ODBC System DSNs for both cluster's servers (each server has 2 ODBC System DSN: One for the 32 bits client and another for the 64 bits client. ) I tested all these ODBC configurations and they seem to be set up properly. These ODBC System DSN have the same name as the ODBC System DSN in the QA environment, as I am pointing the

When the problem came up, I thought the it could be related to the Oracle installation in the PROD Cluster, so what I did, was to locally create a simple CR report which uses data from a single Oracle table. Then I published it directly into the PROD environment and set up its Database Configuration

The same way as for the 23 CR reports that have the problem. However, I can view this report properly and refresh it from within the BOE server.

So I am a bit lost regarding this behavior

The technical details of my deployment are these:

Oracle DB version : 10g Enterprise Edition Release

SAP BOE server: 4.0 SP 10 Patch 01

Crystal Reports: 2011

Any advise will be greatly appreciated


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 15, 2015 at 06:35 PM

    Crystal reports server processes in BI4.1 aree 32bit, so for crystal you only need 32 bit db clients.

    Do these failing reports have correct DB connection info in the prod system (CMC>report properties) ?

    Also, maybe the difference is with the actual tables in the reporting DB ?
    Are you sure same tables exist in prod as in dev ?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Bharath

      I was able to go through the Rights Test View option and I could confirm that the Business View is visible for the account I was using to run the report.

      I think I was not able to find a reason why this error was happening. As it became more and more evident that the BO Repository objects used for dynamically prompting were not to blame on this case, I tried something else, so I was able to figure out a workaround for it

      I hope I'm clear enough as I describe the steps I followed:

      As I said before, every single report I created, is made up of 2 parts: A Main Report which displays a Subreport (within the Main Report footer section). I suspected something in either the main Report or in it's Subreport was wrong. So I choose 1 out of my 23 reports in order to make a deeper analysis.

      1. I edited the main Report and saved the subreport as a separate CR Report file ( by right clicking on the subreport object within the Main Report).
      2. Then I tried to save this separate CR file to the BOE server, which I did successfully. Then I executed this new report in BOE, by providing it with the parameter values which would otherwise be passed from the main report. This report was executed properly. So, I thought the problem was not in the subreport but in the Main Report.
      3. I opened up the Main Report and deleted the Subreport from it, in order to make a simpler scenario. I tried to save the just changed report to the BOE server, as I said in previous posts, the Internal Error: The Report Application Server failed message came up.
      4. Since the Main Report goal is to pre-calculate some values, before these values are passed into the Subreport (as Parameters), I had the idea to generate a brand new Main Report from scratch, which would do exactly the same as the failing Main Report. When I had this new Main Report done, I published it successfully to the BOE server.
      5. I executed the new Main Report successfully in BOE.
      6. Then I modified the new Main Report. I inserted into it, the CR file which I created in step 2 (as a Subreport)
      7. I changed the Sub Report links in order to pass the pre-calculated values from the new Main Report into the Subreport
      8. I saved again this new Main Report into BOE server and now, and as in step 4, I did not get the Internal Error: The Report Application Server failed message
      9. I re set the DB configuration settings for this the new Main Report in BOE and executed  it with no problems at all.
      10. I repeated the steps 1 through 9 for all the remaining 22 reports. I had not problems with any of them.

      So, I could not exactly say why was this happening, if there was something wrong while promoting these reports from my QA environment (although I didn't get any errors when did so).

      I'd had liked to have been able to get to the root of the problem, but unfortunately it was less costly for me to figure out a workaround than to keep working in a more "scientific" approach. Moreover when these reports are about to be used in the PROD environment.

      Thanks a bunch for your support

      Best regards


  • Oct 15, 2015 at 06:32 PM

    Check Business view manager has all related objects in PROD.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Bharath

      Actually, yes, I was able to Schedule the LOVs successfully in the BV Manager:

      The account that I'm using to view the report on demand is the Administrator account. In fact, with other user accounts I was not being able to see the LOVs values while trying to execute the report in CR Designer, so I had to explicitly specify rights at all levels for all the Business View Objetcs in the Repositoty (Data Foundation object and every singe column of it, Business Element object and every single column of it, Business Views, List of Values and Prompt Groups ) like this:

      I open the reports from their server location using CR Designer and after that, I was able to see the LOV values, so I think Business View Manager objetcs' rights setup is not an issue here.

      Thanks for your help.