Skip to Content

Not able to record Operation based defects using QIRF_GET_DEFECT_ITEMS

Hi Experts,

I am trying to post Operation based defects using the remote enabled Function module - "QIRF_GET_DEFECT_ITEMS".

Please find below my test data,

I am getting error noted below, even after providing PLNFL (Sequence number) with 0001 or 0010.

I am a MII consultant with limited QM or even GUI knowledge,

kindly guide with the sequence creation and assignment to the lot as required.

With regards,

Poni

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Oct 13, 2015 at 09:35 AM

    Hi Poni,

    In your case, you are trying to post operation defect which corresponds to record type Q91.

    For this type, you need to give the following fields:

    • PRUEFLOS,
    • PLNFL,
    • VORNR

    As shown by the screenshot below, the system will issue error 177 if one of these fields are missing.

    In addition, for record types Q91 and Q95, the report type is determined from table TQ86A based on the operation data (plant and work center). The entry is used each time with the subsystem indicator set.

    This means you also need to check your customizing (SM30 for the view V_TQ86A) and check if there is a line with the combination of plant and work center related to your operation. This line should exist and should have the indicator subsystem checked.

    Let me know if this solves your issue.

    Regards,

    Ayoub.


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.