Skip to Content
avatar image
Former Member

java.lang.VerifyError

Hello,

I am trying to Migrate a j2ee application to SAP WAS.

While deploying I am getting the below mentioned error

java.lang.VerifyError: (class:

com/sun/j2ee/blueprints/waf/view/taglibs/smart/ClientStateTag, method:

doEndTag signature: ()I) Incompatible object argument for function call

Initially I was using JDK 1.4.2 and JRE 1.4.2.

However after getting the VerifyError I upgraded both JDK and JRE to

1.4.2_07.

I even tried with JDK 1.4.2_07 and JRE 1.3.1_17.

Howevere the error is still persisting.

Note : I am using the J2ee.jar and I feel there is some compatibility

issue with regard to this jar file working with jRE 1.4.2 / 1.4.2_07/ 1.3.1_17.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Feb 09, 2006 at 12:42 PM

    hi Neetu,

    There is generally a problem with this JRE version. Why not you try using JDK 1.4.2_09? Even SAP recommends using this JRE version for all installation of WAS.

    Regards

    Arun

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi neetu,

      Are you running a <b>Enterprise Portal</b> Application? if so, i've the solution.

      Regards

      Arun.

      Message was edited by: Arunkumar

  • avatar image
    Former Member
    Feb 09, 2006 at 01:22 PM

    Hi Arun,

    Even I am facing the same error.

    But I am getting this while trying to deploy my WebDynpro Application directly from NWDS.

    SAP WAS requires JDK to be minimum 1.4.1

    As per ur mail I am trying to install both JDK and JRE 1.4.2_10.

    Lets hope for the best:-))

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Actually,I guess the problem is link to SQL server,we are using The SQL server 2000

      This is the error

      ERROR 2006-02-21 22:12:30

      CJS-20065 Execution of JLoad tool 'C:\j2sdk1.4.2_09/bin/java.exe '-classpath' './sharedlib/antlr.jar;./sharedlib/exception.jar;./sharedlib/jddi.jar;./sharedlib/jload.jar;./sharedlib/logging.jar;./sharedlib/offlineconfiguration.jar;./sharedlib/opensqlsta.jar;./sharedlib/tc_sec_secstorefs.jar;C:\usr\sap/DP1/JC00/j2ee\jdbc\base.jar;C:\usr\sap/DP1/JC00/j2ee\jdbc\util.jar;C:\usr\sap/DP1/JC00/j2ee\jdbc\sqlserver.jar;C:\usr\sap/DP1/JC00/j2ee\jdbc\spy.jar;C:/usr/sap/DP1/SYS/global/security/lib/tools/iaik_jce_export.jar;C:/usr/sap/DP1/SYS/global/security/lib/tools/iaik_jsse.jar;C:/usr/sap/DP1/SYS/global/security/lib/tools/iaik_smime.jar;C:/usr/sap/DP1/SYS/global/security/lib/tools/iaik_ssl.jar;C:/usr/sap/DP1/SYS/global/security/lib/tools/w3c_http.jar' '-showversion' '-Xmx512m' 'com.sap.inst.jload.Jload' '-sec' 'DP1,jdbc/pool/DP1,C:\usr\sap\DP1\SYS\global/security/data/SecStore.properties,C:\usr\sap\DP1\SYS\global/security/data/SecStore.key' '-dataDir' 'E:/J2EE/DVD_NW_04_SR1_SAP_Web_AS_JAVA\J2EE_OSINDEP\J2EE-ENG/JDMP' '-job' 'C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_JAVA\ONE_HOST/IMPORT.XML' '-log' 'C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_JAVA\ONE_HOST/jload.log'' aborts with returncode 1. Check 'C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_JAVA\ONE_HOST/jload.log' and 'C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_JAVA\ONE_HOST/jload.java.log' for more information.

      and this is Jload.log

      21.02.06 22:12 com.sap.inst.jload.Jload main

      INFO: Jload -sec DP1,jdbc/pool/DP1,C:\usr\sap\DP1\SYS\global/security/data/SecStore.properties,C:\usr\sap\DP1\SYS\global/security/data/SecStore.key -dataDir E:/J2EE/DVD_NW_04_SR1_SAP_Web_AS_JAVA\J2EE_OSINDEP\J2EE-ENG/JDMP -job C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_JAVA\ONE_HOST/IMPORT.XML -log C:\Program Files\sapinst_instdir\NW04SR1\WEBAS_JAVA\ONE_HOST/jload.log

      21.02.06 22:12 com.sap.inst.jload.Jload main

      SEVERE: couldn't connect to DB

      java.sql.SQLException: [SAP NetWeaver][SQLServer JDBC Driver]Unable to connect. Invalid URL.

      Thanks for your help,

      Maryam

  • avatar image
    Former Member
    Feb 16, 2006 at 11:39 AM

    hi,

    i think the problem is regarding the doEndTag() signature.

    So, pliz check out the link.

    http://help.sap.com/saphelp_nw04/helpdata/en/bb/d34004e75dcf4c84529c83879c739d/content.htm

    hope it helps.

    regards

    mujjammil

    Add comment
    10|10000 characters needed characters exceeded