Skip to Content
avatar image
Former Member

Timezone of J2EE Engine does not match timezone of the diag. agent

Dear Team,

We are  getting following error in managed configuration of Solution manager.

Error message:

This error message means that the J2EE server's JVM uses a differenttimezone than the Diagnostics Agent's JVM.To check the timezone of the J2EE Engine:Open the instance.properties file of the J2EE Engine on the managedsystem.Locate the parameter "-Duser.timezone=" and its value.If the -Duser.timezone parameter is not set, the JVM uses GMT bydefault.To set the timezone of the Diagnostics Agent:Locate the smd.properties file.Add the -Duser.timezone= parameter with the same time zone as configuredfor the J2EE engine.Restart the Agent.



Please find the attached screen shot for your reference...



Kindly advise,


Regards,

IMRAN.

time.png (285.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 12, 2015 at 04:02 AM

    Hi Imran,

    Have you tried the steps mentioned in the details section? If not, then please perform the same and restart the application.

    For Java instance

    first check the instance.properties for this parameter, if the same exists, then modify it as per your requirement in configtool and restart your instance. Directly changing in instance.properties wont help as during the bootstrap process instance.properties file will get overwritten.

    If the parameter doesn't exist, follow below steps

    1) open config tool                                                                                                   

    2) select cluster-data->instance<>->server<>    

    3) add new line -Duser.timezone=<timezone> and save

    4) Restart your instance

    if the SMD agent has wrong settings then make the change in smd.properties file and take a restart

    Hope this helps

    Regards

    Aditya Khorana

    Add comment
    10|10000 characters needed characters exceeded