Skip to Content
author's profile photo Former Member
Former Member

SAP report problem no connection when promoted with connection

Hi Community Members!

I have a little problem with one of my WEBI reports. As I was informed it have worked on DEV some time ago, and now there are problems related. Same report promoted earlier to PRD works fine.

On DEV when i go to properties of report -> Default Settings -> Report Universes on DEV it sais in connection section - (no connection).

Even, when it's the same connection on DEV and PRD, both works fine (at least in universe design tool).

In Rich Client buton to refresh data is not active.

When i try to view report from CMC and refresh data, i get two errors:

when trying to refresh the only one query i get:

Universe data connection could not be found. The connection has been deleted or you don't have the right to use it. (Error: INF )

When i try to refresh all (i have just one query) i get an error:

An internal error occured while calling 'processDPCommandsEx' API. (Error: ERR_WIS_30270) (Error:INF )

I've checked rights (i'm using administrator account) and looks ok - admin has inherrited full control, everyone has no set rights there.

Environment SAP Business Intelligence 4.1SP6.

Can anyone help?

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Oct 09, 2015 at 12:35 PM

    Make sure the CUID of the connection is same in both environments.It looks like your connection CUID out of sync.

    As Rajshree mentioned,open the universe in IDT or Universe desginer depending on your universe type, repoint the universe to connection and save and publish it.

    Or Better approach is Delete the connection in destination environment, promote the universe along with connection to destination.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Shiva Vishnubatla

      Thats right. I knew that i have to change source when making copy but i forgot to do it.

      The most possible cause of the problem was usage of client tools in version 4.1sp5 against server version 4.1sp6.

      After updating datasources reports works again.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 09, 2015 at 12:03 PM

    Hi,

    Do you see the connection in CMC?

    The universe connection might be corrupted in the Central Management Server (CMS). The Web Intelligence report is referencing a universe connection that no longer exists.

    Perform the following steps:

    1. Import the universe into Designer.
    2. Reset the connection information from File > Parameters.
    3. Republish the universe.

    Regards,

    Rajshree

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thx Rajshree for the answer.

      Yes i can see the connection in CMC, it has same CUID as in PROD, but other ID, it should be ok right?

      I've already tried to republish the universe, but that changes nothing.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.