Skip to Content
avatar image
Former Member

Error: EDI: Error while assigning IDoc number

Hi Everybody,

using XI 3.0 on Linux 64 bit SLES9 with Oracle I got some probleme sending messages from mq series to sap:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Adapter

-->

- http://sap.com/xi/XI/Message/30"

xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/"

SOAP:mustUnderstand="">

<SAP:Category>XIAdapter</SAP:Category>

<SAP:Code area="IDOC_ADAPTER">ATTRIBUTE_IDOC_METADATA</SAP:Code>

<SAP:P1>EDI: Error while assigning IDoc number</SAP:P1>

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Error: EDI: Error while assigning IDoc number</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

What is missing here?

Kind regards,

Michael

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Feb 09, 2006 at 08:43 AM

    Hi Michael,

    Hope you have maintained the port for your target system in IDX1 and also the RFC destination used in the port is maintained in SM59. If both are working fine then check whether a test connection from SM59 for your RFC destination is working fine. Check for the existence of the latest version of IDOC type you are using in your target system.

    Cheers

    JK

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      all this didn't help.

      Everything works fine except this point. Also I've checked the number rangers in the XI and the receiving system.

      Also we have 10 dialog processes and 4 batch processes so every RFC connection should be fine.

      Any furhter idea?

      Michael

  • avatar image
    Former Member
    Jan 24, 2014 at 02:26 PM

    Is number range assigned in transaction SNRO for the IDOC? Object you need to check is EDIDOC.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 24, 2014 at 03:37 PM

    Hello MIchael,

    Try clearing the cache using SXI_Cache or do a full cache refresh.

    Also you can try adding Idoc type manually in to IDX2.

    Thanks

    Gaurav Ranjan

    Add comment
    10|10000 characters needed characters exceeded