Skip to Content
author's profile photo Former Member
Former Member

Hide row at Rich Client

Hello,

I would like to hide row at WEBI report which is build based on BEx query. Can someone guid me how can I do it?

I am using WEBI 4.1 SP5.

I have at at columns structure with with Key figure

at WEBI it is visible as single dimention. The report has at column listed above structure with KF and at rows selections based on characteristics.

Can some one guid me how can I delete the marked below row?

when I try to use table properties options I just see hide options which are linked to columns, nothing likned to rows:

how can I handle it? Is it possible to write any formula to hide the row?

struct_bex.png (2.6 kB)
repo_struct.png (14.5 kB)
repo_data.png (6.8 kB)
table_prop.png (19.1 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Oct 08, 2015 at 03:18 PM

    Hi,

    Right click on the column and apply filter and exclude the value.

    or some thing.

    Var=if(structure object="text") then "Hide" else "Show"

    Apply table filter on Var not equal to Hide.

    Amit

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 09, 2015 at 04:24 AM

    Hi Piotr,

    1. As Bex your Source you Use "Function Hide" is present the "Display Tab" of KF properties

    (or)

    2. U can Achieve this by applying filter...As my veiw

    Create Variable as V1=Rank(Kf field)

    Apply filter as "Not equal To" Particular Rank.

    Hope it helps in some ways

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 09, 2015 at 03:06 PM

    Hi,

    thank You for fast feedback. Unfortunately proposed by You solutions do not work for me or I am doing sth wrong. Let me show what I did.

    At Bex I did the settings for KF:

    those setting works fine at Analyzer:

    just raws which all have "0" are not displayed.

    at Webi I see all raws instead of empty or zeros at all row.

    when I apply filter on measure wchich is at row, e.g. "Impot sur.." = 0 then column Ecart % hides instead of hiding the row.

    When I am trying to enter filter on KF then I just have 3 available values 2014, 2015 and Ecart %

    when I have tried to create variable

    1) VAR = If [KF] = "0" Or [KF] = "" Then "HIDE" Else "SHOW",

    2) Apply filter where VAR = "SHOW"

    I have received #UNAVAILABLE

    What I did wrong?

    I am not sire if it is important but the variable was not placed into any of report cell.


    BeX.png (11.9 kB)
    Analyzer.png (13.9 kB)
    BeX_no_f.png (13.5 kB)
    BeX_f.png (17.5 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.