Skip to Content

Unable to reset SYSTEM user's password in SYSTEM DB of SAP HANA SPS10 REV102

Hello All,

I had installed the latest version of HANA database 1.0 SPS10 Revision

102. While trying to install ECC application in the database got the error

below error during Setup data

Hdbcmdout.log shows an error as below:

***********************

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Start new connection with connect URL: jdbc:sap://AFECCHANANP:30013 connect user: SYSTEM

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Instance is a multiple-container system.

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Start new connection with connect URL: jdbc:sap://AFECCHANANP:30013?databaseName=SYSTEMDB connect user: SYSTEM

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Password has changed for user: System

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Start new connection with connect URL: jdbc:sap://AFECCHANANP:30013 connect user: SYSTEM

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Instance is a multiple-container system.

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Start new connection with connect URL: jdbc:sap://AFECCHANANP:30013?databaseName=SYSTEMDB connect user: SYSTEM

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | Error during execution of HdbCmdClazz section!

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.db.jdbc.exceptions.jdbc40.SQLInvalidAuthorizationSpecException: [10]: authentication failed

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.connection.sql.JdbcConnection.establishConnection(JdbcConnection.java:191)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.connection.sql.JdbcConnection.connectToTenant(JdbcConnection.java:161)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.connection.sql.JdbcConnection.createConnection(JdbcConnection.java:116)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.connection.sql.JdbcConnection.getConnection(JdbcConnection.java:248)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.connection.sql.JdbcConnection.prepareSQLCommand(JdbcConnection.java:525)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.instance.DatabaseTenant.exists(DatabaseTenant.java:43)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.cmd.clazz.GetConnectHostsAndPortsMultiDB.execute(GetConnectHostsAndPortsMultiDB.java:63)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.cmd.clazz.BatchExecutionBase.executeCmdClazz(BatchExecutionBase.java:52)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.cmd.clazz.GetConnectHostsAndPorts.execute(GetConnectHostsAndPorts.java:48)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.core.main.cmd.HdbCmdMain.execute(HdbCmdMain.java:113)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.core.main.cmd.HdbCmdMain.main(HdbCmdMain.java:74)

Tue Oct 06 22:24:42 AST 2015 | com.sap.hdb.core.main.cmd.HdbCmdMain | *************************************************************

**************************

As per the above error, looks like the System user password is changed and is not getting connected.
I also tried to connect to HANA studio with the same SYSTEM user and it was throwing the incorrect

user/password error though i gave the right credentials.

I then tried to Reset the SYSTEM User Password of the System Database

by following the below SAP help document:

**************

http://help.sap.com/saphelp_hanaplatform/helpdata/en/c0/1fc0f5d38c47c69204d84a700d0ca7/content.htm?frameset=/en/df/025d7abb5710148ba8b0ed6476b597/frameset.htm&current_toc=/en/00/0ca1e3486640ef8b884cdf1a050fbb/plain.htm&node_id=326&show_children=false

*************

After following the procedure in the above document i changed the SYSTEM

user password. Now when am trying to connect to the hdbsql with the new password changed it throws me

the below error:

***********

<Hostname>:/usr/sap/HDB/HDB00> hdbsql -i <Inst nr> -n <Host name> -d SystemDB - u SYSTEM

Password:

* 10: authentication failed SQLSTATE: 28000

***********

I am also unable to connect to HANA SYSTEM DB in Hana Studio as well with

the SYSTEM USER. Kindly help me on this please.

Regards,

Krishna

pastedImage_5.png (71.6 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Oct 13, 2015 at 12:26 PM

    Hello,

    This was solved after setting the below parameter in nameserver.ini file and indexserver.ini file:

    [password policy]

    password_lock_for_system_user = false

    Regards,

    Krishna

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 07, 2015 at 06:46 PM

    Krishna,

    I have a similar issue in the context of migration of ECC to HANA. I am wondering if it has anything to do with HANA DB SSFS (2210637 - Change the encryption key of hdbuserstore).

    Shabna

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Shabna,

      The note was helpful!


      As per the Note: 2183624 I first stopped the database, just included the cryptography parameter:

      ssfs_key_file_path and then started the database and then i was able to connect to the database using the SYSTEM user. I was also able to connect from HANA Studio where it just asked to reset the SYSTEM user password which i did.

      Then I ran the installation again with the old option and it crossed the error step and then i received another authentication failed error at the start of Import ABAP phase. I then terminated the installation and then started a fresh installation now and again I got the same error as I reported first at "setup database connection information" phase and am not able to connect with SYSTEM user again.

      This time i completely followed the suggestions of note: 2183624 and still the same error persists for me.

      I also tried to change the SSFS master keys for both the instance SSFS and the system PKI SSFS as suggested in the below help link but the same error still persists for me:

      ***************

      https://help.sap.com/saphelp_hanaplatform/helpdata/en/58/1593c48739431caaccc3d2ef55c23f/frameset.htm

      **************

      Am i missing out on something. Kindly help me on this. Thanks again.

      Regards, Krishna

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.