Skip to Content

Error When Copying Decimal Values

Hello everyone,

I have an odd problem in a solution of mine --- I have a custom BO which is used to create customer invoice requests (CIRs) using some values taken from a record of another custom BO. During the AfterModify script which creates this CIR (an XML file input is used to trigger the script), I try to copy some data from fields in the single record of the second custom BO, into matching fields I've put in an XBO for CIR. The odd thing is that the script just stops as soon as it tries to parse the lines which copy the values --- no error message that I can see of any kind. If the fields I'm writing to were read-only it'd say so when I tried to activate the AfterModify script I think. Can anyone shed some light on this?

You'll notice I'm using 'instCustomerInvoiceRequest', which as you can see is the name of the newly-created CIR instance. I also tried putting the same functional code, but using 'elementsofCIRRoot' pre-creation of the CIR.

Many thanks.

Lewis

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Oct 08, 2015 at 05:29 PM

    So what is the actual error? Is there any information in the Dump Analysis window?

    Are there any warnings or similar left in your error list?

    Regards,

    Thomas

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 08, 2015 at 01:20 PM

    Hello Lewis,

    Are you sure that the query return any entry?

    Even a GetFirst on an empty list is initial. 🤯

    HTH,

    Horst

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.