Skip to Content
avatar image
Former Member

Run installer error while doing homogenous system copy

Hello All,

I am doing Homogenous system copy on AIX with oracle 11g.

In the phase of oracle db software installtion .

I have installed the the same what mentioned going to stage.../SAP directory.

There are 2 folders are created 11203 and 112_64.

After doing this If I continue still getting the same error message.

It seems oracle db software not installed .. but in folders /oracle/<SID>11203 all the files are created.

Kindly suggest is any thing need to do further.

Thanks

Sri

1.jpg (101.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Sep 30, 2015 at 12:37 AM

    Hi Sri,

    Please check the environment variables of user sidadm. Also please attach sapinst_dev.log to this discussion.

    best regards,
    James

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 30, 2015 at 03:14 AM

    Hi Sri,

    Could you share sapinst_dev.log file to support you for the issue.In addition could you share result for command

    sqlplus /nolog

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 30, 2015 at 04:45 AM

    Hello Sri,

    Are you getting this error while doing import ? 11203 is the soft-link for 112_64.  if oracle database is install than try to login the oracle is working or not. kindly give more details on this issue.

    Thanks,

    BM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 30, 2015 at 05:39 AM

    Hi ,

    Below are the details.

    1. softlink is created , sending screen shot kindly validate it.

    2. Able to login as /sqlplus nolog

    3. Attaching sapinst dev log file.

    Please guide me how to proceed further.

    Thanks

    Sri


    ln.PNG (78.4 kB)
    sql.png (23.0 kB)
    sapnt.png (193.2 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Brindavan Mookaiah

      Hello Sri,

      Do check as mentioned by brindavan for the permission. also can you please update us with below environment variables.

      ORACLE_HOME & ORACLE_BASE.

      Do check those. also you can try to set the oracle_home to /oracle/PRD/112_64 or /oracle/PRD/11203.

      And try to re-run the installer again.

      also hope your running installed with prdadm and all the environment variables are set correctly.

      Do verify your LD_LIBRARY path and oracle environments(oracle_HOME, TNSADMIN).

      Do let us know the status.

      regards,

      Ram

  • avatar image
    Former Member
    Sep 30, 2015 at 08:56 PM

    Hi

    Thanks for the response


    1. As mentioned by brindavan i have changed the  oracle filsystem owner"112_64"  from root to oraSID :dba

    even the installation is unable to proceed, the issue is still same. could  you please suggest me what should  i better to check further steps


    2.as mentioned by  james here am enclosed the link of sapinst_dev.log, kindly check the log Please guide me how to proceed further.


    https://drive.google.com/open?id=0Bzf2lXnFaKOlZGZKTFNPNzdDNG8

    Thanks sri


    Add comment
    10|10000 characters needed characters exceeded

    • Hi ,

      Cross check once again all the oracle file in directories 11203 inside, all the files should be ora<SID>:dba. check the listener running or not. check the oracle is not idle.

      . check the "/oracle/SID/oraInventory ".

      let me know the result for the below commands

      ORASID> echo $ ORACLE_HOME

      ORASID> echo $ ORACLE_BASE

      ORASID> echo $ ORACLE_SID

      Thanks,

  • avatar image
    Former Member
    Oct 01, 2015 at 03:35 AM

    Hi,

    Not able to access the file shared by you,kindly provide the access to fetch the same or attach it with your thread.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 05, 2015 at 03:24 AM

    Hi Sri,

    Could you share tnsnames.ora file or try to check the correct host name / IP address of the server in it.Additionally maintain the host entries as like

    127.0.0.1  localhost.localdomain  localhost

    <Server IP Address >  <Host Name>

    Please confirm.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Sri,

      Have you tried to set up oracle_HOME with /oracle/PRD/11203 your oracle version.

      and LD_LIBRARY path with /usr/sap/PRD/DVBM*/SYS/exe:/oracle/PRD/11203/

      And re-tried sapinst/SWPM.

      Regards,

      Ram

  • Oct 05, 2015 at 10:52 AM

    Hi

    Sometime SWPM/SAPInst tool doesn't know the newly installed database software or its location.

    To resolve this,

    1)  just come out of SWPM/SAPInst. tool, means just exit it.

    2) From the same telnet session,  set  below env. variables for the newly installed DB/software

    export DB_SID=SID

    export ORACLE_SID=SID

    export ORACLE_HOME=OracleHomeDirectory

    3) then, Re-Start SWPM/SAPInst tool

    Now, SWPM/SAPInst able to recognize the db and its software location, so installation tool can be continued from its earlier phase..

    regards

    Swami

    Add comment
    10|10000 characters needed characters exceeded