Skip to Content

Error: Invalid or no assignment to system datatype found

Hi All,

I am trying to get some data from the back-end with SAP Gateway. I have created a data model, generated and implemented the get_entityset for my entity. When i call the service, the output data is filled correctly after the get_entityset is executed.

The problem appears when the Gateway tries to convert the data into JSON format. An exception is thrown and an error appears in the Gateway log too, which states that there is an invalid or no assignment to system datatype. I checked the data model in the Gateway, regenerated the runtime artifacts, but I still get the same error.

This is my data model:

Any ideas what the problem might be?

Thanks,

Szilamér

Capture.JPG (244.7 kB)
Capture.JPG (126.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Sep 29, 2015 at 09:14 AM

    Hi,

    Check whether for your entity type media check box is checked. If it is so, uncheck the media checkbox and generate again runtime artifacts and execute the service.

    See below screen shot for entity types.

    Regards,

    Venu

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      thanks for the suggestion!

      The problem disappeared this morning, after I executed the request in the Gateway Client, though I can't be entirely sure that this was what caused the problem to disappear. I haven't modified anything in the data model or the implementation. It just started working without any logical reason that I can think of...

      BR,

      Szilamér