Skip to Content
author's profile photo Former Member
Former Member

On-Demand Subreport Requires Database Logon

Hi,

I have read all the posts regarding this topic on the forums and have tried the solutions, to no avail.

I have a report with a subreport. Both are pointing to the same Oracle server temp_table and stored procedure.

As of last week, this report ran fine in BI Launchpad and Central Management Console.

Now, when the report is run with the Database Configuration setup to "Use same database logon as when report is run", even though the main report and subreport point to the same table, the subreport is empty.

When I change the option of "When viewing and scheduling report" to "Prompt the user for database logon (viewing only)", I am able to go through the process of running the report, logging on for the subreport and getting data in both main and subreport.

Again, I have set and reset the database location and verified it. The only change I've made to the report in the last week is adding a "no data found" message that looks for a field to be null, then display the message.

I am using SAP BusinessObjects BI Platform 4.1 Support Pack 5 Patch 2 (Version 14.1.5.1568).

I am using Crystal Reports 2013 Support Pack 5 Path 2 (Version 14.1.5.1568).

What am I missing?

Thank you,

Erin

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Sep 21, 2015 at 06:59 PM

    Hi again,

    So an update... Another report is having issues with the custom database configuration. When run with that option, all fields completed, the report returns no data. If I clear the Database field, I return data. If I use the original database logon information, I return data.

    Don't know if these two are related - am trying to get in touch with the admins, but maybe the problem is higher up?

    Thank you,

    Erin

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member JinChong Tsai

      Hi Jin-Chong,

      Would you believe that my work Internet access is so locked down that I can't access this document?

      Unfortunately, I cannot do anything in an administrative capacity, so I'm going to forward your message to those who can. Maybe they'll have better access than I do and can read this. I'll be sure to look when I get home.

      Thank you again!

      Erin

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.