/scripts/ahub.form.attachments.js
0

SAP HANA ERROR DELETED VIRTUAL TABLE

Feb 02, 2017 at 02:54 PM

530

avatar image
Former Member

Hello, We need to deleted a virtual table created from table T000. The name of the table is TQA_HANA_T000.

In Eclipse we use the sentence "DROP TABLE TQA_HANA_T000 CASCADE" , actually we have deleted a lot of tables, but this virtual table give us a error.

The error is:

Could not execute 'DROP TABLE TQA_HANA_T000' in 140 ms 907 µs .
[301]: unique constraint violated: Table(P_OBJECTDEPENDENCY_), Index(_SYS_TREE_RS_#132220_#0_#P0)

If we try with de code:

DROP TABLE TQA_HANA_T000 RESTRICT

Give us another error:

Could not execute 'DROP TABLE TQA_HANA_T000 RESTRICT'
SAP DBTech JDBC: [419]: can't drop with RESTRICT specification: TQA_HANA_T000: line 1 col 12 (at pos 11).

Any idea why this error ?

As a comment the client performed a mandant copy from ERP PRD to ERP QAS which affect the chema name, that is why we need to deleted this virtual table to create a new one whit the same name.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member Jun 07, 2017 at 02:55 PM
0

hey - did you get find a solution to this? we are getting the exact same error message when dropping a virtual table in HANA. not able to find a way around it :(

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

I found this OSS note that describes the solution for this issue. - I followed the workaround suggested here (redeploying all the dependent Calc Views) and it worked.

2365678 - Dropping a Virtual Table Fails with Error Message "unique constraint violated: Table(P_OBJECTDEPENDENCY_), Index(<index>)"

0
avatar image
Former Member Jun 20, 2017 at 01:38 AM
0

I am also struggling with this.

I think I may have found why this happens and if you see the content of the view: SYS.OBJECT_DEPENDENCY - you will see the dependent CVs using the table function.

However, how do I force the deletion even if they are used in the CVs is the question?

Regards
Debanshu

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Sep 05, 2017 at 02:07 PM
0

Hi.

Did you find any way around this?

I'm getting the same error now on a Virtual Table created in BW HANA database based on CV in ECC system (connected via Smart Data Access).

The Virtual Table is used as source into a Open ODS View in BW system.

New fields has been added in CV in ECC system, and for these fields to be available for Open ODS View, we need to delete and recreate Virtual Table.

regards

Oddmar

Share
10 |10000 characters needed characters left characters exceeded
Skip to Content