Skip to Content
author's profile photo Former Member
Former Member

runnable process search count

I m upgrading ASE to

Adaptive Server Enterprise/15.7/EBF 23823 Cluster Edition SP132 /P/RS6000/AIX 61/ase157sp131x/3919/64-bit/FBO/Tue Jan 20 07:36:36 2015

I need to modify config parameter:

1> sp_configure 'runnable process search count',2500

2> go

but getting the error below

Msg 15940, Level 16, State 3:

Server 'tv_production_st2', Procedure 'sp_configure', Line 1824:

This command is not supported in threaded mode. To achieve the same result in

threaded mode, use the 'alter thread pool' command to change 'idle timeout'.

Msg 5849, Level 16, State 1:

Server 'tv_production_st2', Procedure 'sp_configure', Line 1824:

Verification failed for parameter 'runnable process search count'.

(return status = 1)

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Sep 17, 2015 at 03:06 PM

    Milan

    You are running the ASE server in new default 'threaded kernel' mode.

    You can verify this by following command

    exec sp_configure ' kernel mode'

    go

    And it will show the current value. It is a static parameter i.e. needs a reboot if you change it.

    As the error message clearly says "runnable process search count" is useful only when you run ASE in 'process kernel mode' where each engine is separate Unix process.

    You can find more details in the two volumes of ASE System Administration Guides.

    HTH

    Avinash

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 17, 2015 at 02:45 PM

    Hello Milan,

    I move this to SAP ASE custom applications as the ASE version is cluster edition. Please post future questions there.

    10Q!

    - Gek

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 17, 2015 at 03:23 PM

    Others have already commented on the fact that ASE's threaded kernel uses a different model than the process kernel. Thread pools have an idle timeout defined in microseconds. Rarely would you need to change this.

    Out of curiosity, why were you thinking you needed to change "runnable process search count"?

    Peter

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.