Skip to Content
avatar image
Former Member

Geocoder returns lat/long with comma and points

Hello community,

I'll appreciate some clue or solution for the next strange issue we're facing.

Our environment is: SAP Data Services 4.2 SP05, with de Data Quality package and the Spanish directory.

We want to cleansing + geocoding the direction of the business partners in the ERP environment of our customer. We've found that in some cases, the latitude / longitude is retrieved by a decimal number built with a comma despite of the point we expect between the integer and the decimal part of the decimal number retrieved.  In other words, in some cases, always the same BusPartners, the value retrieved has the form of: '00,00000' despite of '00.0000'

To take into account: next images shows the of the geocoder object output.

Example 1 - Result with comma:

(input)

- Street. barri Segalers

- HouseNo. 2

- Postcode. 08261

- Locality. Cardona

- Country. ES


(geocoding process)


(Result)

Latitude: 41,000000

Longitude: 1,000000

Example 2 - Result with point (correct one)

(input)

- Street. ps Comerç

- HouseNo. 92

- Postcode. 08203

- Locality. Sabadell

- Country. ES


(geocoding process)


(Result)

Latitude: 41.5298789,

Longitude: 2.1093916



That's the XML output:


<Record><ID>FC001</ID>

<COUNT>0</COUNT>

<SERVICE>GEOCODING</SERVICE>

<FIELD>LATITUDE</FIELD>

<VALUE>41,000000</VALUE>

</Record>

<Record><ID>FC001</ID>

<COUNT>0</COUNT>

<SERVICE>RESULTS</SERVICE>

<FIELD>4</FIELD>

<VALUE>The result from geo-coding is ambiguous. There is no choice available because the address data was not clearly specified.</VALUE>

</Record>

<Record><ID>FC001</ID>

<COUNT>0</COUNT>

<SERVICE>GEOCODING</SERVICE>

<FIELD>LONGITUDE</FIELD>

<VALUE>1,000000</VALUE>

</Record>


OK. So, after the global data cleansing done in the step before joining in the geocoder...the normalized direction couldn't be found in the GeoCoder.  😕


Is there any option or way to customize the form of the data retrieved by the geocoder in DS or in the IMG customizing in the ERP? I don't know where I should keep on looking for solving it.


Could be the directory out of date?

*Could be related: The Code Page is set up to UTF-8 (as the DQ user guide points) in the SAP DS Locale Selector, the language and territory is set up by default.

Thank you very much in advance to everyone,

Regards.

Message was edited by: Néstor Martínez

example1.png (32.6 kB)
example2.png (37.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Sep 15, 2015 at 08:31 AM

    Still having that issue.

    Could be that the GAC and the Geocoder directory doesn't have the same version release? And they couldn't understand to each other? Because the GAC has any directions that geocoder hasn't?

    thank you in advance,

    Add comment
    10|10000 characters needed characters exceeded