Skip to Content

BP DataSources not extracting data

Hi friends,

I have activated on ECC 3 datasources for loading business partner (BP) related BW InfoObjects and then replicated their metadata on BW. DS's are: 0BP_BANK_ATTR (SAP BP: BW Extraction Bank Data), 0BP_CCARD_ATTR (BP: Payment Card (Attributes)) and 0BANKKEY_TEXT (Bank Key)

I tested the 3 datasources on RSA3 (update mode F) and data is available for all of them on the ECC. But for some reason none of them are extracting data on BW. I have tried extracting with the business content init delta InfoPackages and also with custom full update mode packages, but the monitor always shows status 8 "no data available".

Extractors have been replicated as 3.x emulated (ISFS). Their delta processes, seen on RSA2, are:


0BP_BANK_ATTR and 0BP_CCARD_ATTR: AIM After-Images Via Delta Queue

0BANKKEY_TEXT: A ALE Update Pointer (Master Data)


Another AIM BP extractors like 0BPARTNER_ATTR are working fine.


I have activated ALE and update pointers Function Modules on IMG but I saw no benefit on 0BANKKEY_TEXT DS.

I believe I'm missing a prerequisite step on the ECC side. Any help will be highly appreciated and of course awarded.

Regards,

Fernando

nodata.jpg (40.6 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Sep 21, 2015 at 02:00 PM

    Hello Fernando, Could you please check if the table ROOSOURCE for these datasources 0BP_BANK_ATTR, 0BP_CCARD_ATTR AND 0BANKEY_TEXT has the last date for version "A" related to "D" version? if the date for "A" version is posterior than the "D", please do the following steps: 1) CRM: RSA5, re-activate the involved datasources 0BP_BANK_ATTR, 0BP_CCARD_ATTR AND 0BANKEY_TEXT 2) bw: datasource replication 3) bw: transferstructure re-activation 4) bw: re-initialization 5) bw: delta loading Also, Did you check if there any failed entry in tx.code RSA7 for those datasources? I hope this can help you. Thanks and best regards, Jose Francisco Fernandes

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.