Skip to Content
avatar image
Former Member

PO to PI Integration compatibility due to different versions

Hello Team,

Is it possible to have 2 PI systems interacting with each other on different Netweaver versions.

PI version is 7.02

PO 7.4 SP09

Due to few constraints, we would like to implement interface with following participating systems:

SAP ECC 6.0 Ehp7-->PO7.4 SP09 -->PI7.02 -->AII 7.10 sp12

In above context, Kindly confirm if PO 7.4 SP09 (only Java) can communicate to PI 7.02 using Idoc connectivity or other.

Kindly help on same.

Has somebody practically tried 2 PI system interacting, having different netweaver versions.

Kind Regards,

Anurag Garg

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Sep 03, 2015 at 02:35 AM
    Has somebody practically tried 2 PI system interacting, having different netweaver versions.

    Yup, this is not a problem at all. Check out the following thread on using the SOAP adapter with XI3.0 protocol to connect two PI/PO systems.

    SOAP would be the best instead of IDoc, and you can either use the SOAP 1.1 protocol mentioned above or XI3.0 mentioned in the thread.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Hareesh Gampa

      I got it Harish.

      Many Thanks.

      I will try the scenario with both the options and will come back in case of any issues.

      Kind Regards,

      Anurag

  • Sep 02, 2015 at 01:52 PM

    >>>using Idoc connectivity or other.

    You can make use of SOAP adapter(HTTP/SOAP 1.1)  to connect to your second PI system.

    Add comment
    10|10000 characters needed characters exceeded