Skip to Content
0
Former Member
Sep 01, 2015 at 06:20 AM

ECC system not able to connect with HANA database

4982 Views

Hi Gurus,

We have ECC6.0 EHP7 system with HANA database installed. And recently our HANA db server USALVLHANADB was moved to another data center. Since then ECC system is not able to connect with hana db.

SAP HANA databse is up but not able to connect with SAP Server ECC6.0 EHP7

R3trans -d is failing with error.

Below trans.log

4 ETW000 [ dev trc,00000] Loading SQLDBC client runtime ... 25 0.009258

4 ETW000 [ dev trc,00000] SQLDBC Module : C:\usr\sap\E74\hdbclient\libSQLDBCHDB.dll 1631 0.010889

4 ETW000 [ dev trc,00000] SQLDBC Runtime : libSQLDBCHDB 1.00.81.00 Build 0392776-1510 80 0.010969

4 ETW000 [ dev trc,00000] SQLDBC client runtime is 1.00.81.00.0392776 48 0.011017

4 ETW000 [ dev trc,00000] -> getNewConnection() 34 0.011051

4 ETW000 [ dev trc,00000] <- getNewConnection(con_hdl=0) 107 0.011158

4 ETW000 [ dev trc,00000] -> checkEnvironment(con_hdl=0) 57 0.011215

4 ETW000 [ dev trc,00000] -> connect(con_info_p=0000000000000000) 48 0.011263

4 ETW000 [ dev trc,00000] Try to connect via secure store (DEFAULT) on connection 0 ... 72 0.011335

4 ETW000 [ dev trc,00000] Mon Aug 31 05:00:47 2015 21018328 21.029663

4 ETW000 [dbhdbsql.cpp,00000] *** ERROR => Connect to database failed, rc=1, rcSQL=-10709 56 21.029719

4 ETW000 [ dev trc,00000] SQLCODE : -10709 41 21.029760

4 ETW000 [ dev trc,00000] SQLERRTEXT : Connection failed (RTE:[89006] System call 'connect' failed, rc=10060:A connection attempt failed be\

4 ETW000 53 21.029813

4 ETW000 [ dev trc,00000] cause the connected party did not properly respond after a period of time, or established connection\

4 ETW000 47 21.029860

4 ETW000 [ dev trc,00000] failed because connected host has failed to respond) 28 21.029888

4 ETW000 [ dev trc,00000] -> SetSdbDbslCA(errcode=-10709) 33 21.029921

4 ETW000 [ dev trc,00000] -> freeConnection(con_hdl=0) 60 21.029981

4 ETW000 [ dev trc,00000] close all opened locators of connection 0 38 21.030019

4 ETW000 [ dev trc,00000] } DbSlHDBConnect(rc=99) 72 21.030091

4 ETW000 [ dblink ,00000] ***LOG BY2=>sql error -10709 performing CON 61 21.030152

4 ETW000 [ dblink ,00000] ***LOG BY0=>Connection failed (RTE:[89006] System call 'connect' failed, rc=10060:A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond)

4 ETW000 63 21.030215

4 ETW000 [ dev trc,00000] { DbSlHDBControl(con_hdl=0,command=41,arg_p=0000000140022E58) 82 21.030297

4 ETW000 [ dev trc,00000] } DbSlHDBControl(rc=0) 40 21.030337

4 ETW000 [ dev trc,00000] { DbSlHDBControl(con_hdl=0,command=14,arg_p=0000000002065D28) 31 21.030368

4 ETW000 [ dev trc,00000] } DbSlHDBControl(rc=0) 27 21.030395

4 ETW000 [ dev trc,00000] { DbSlHDBControl(con_hdl=0,command=50,arg_p=0000000002065D20) 30 21.030425

4 ETW000 [ dev trc,00000] } DbSlHDBControl(rc=0) 36 21.030461

4 ETW000 [ dev trc,00000] { DbSlHDBControl(con_hdl=0,command=13,arg_p=0000000002065D40) 31 21.030492

4 ETW000 [ dev trc,00000] } DbSlHDBControl(rc=0) 25 21.030517

4 ETW000 [ dev trc,00000] { DbSlHDBControl(con_hdl=0,command=52,arg_p=0000000002065D90) 29 21.030546

4 ETW000 [ dev trc,00000] } DbSlHDBControl(rc=0) 27 21.030573

2EETW169 no connect possible: "DBMS = HDB --- SERVER = '' PORT = ''"

DEV_W0 logs:

Loading SQLDBC client runtime ...

C SQLDBC Module : C:\usr\sap\E74\hdbclient\libSQLDBCHDB.dll

C SQLDBC Runtime : libSQLDBCHDB 1.00.81.00 Build 0392776-1510

C SQLDBC client runtime is 1.00.81.00.0392776

C

C Try to connect via secure store (DEFAULT) on connection 0 ...

C

C Mon Aug 31 05:37:33 2015

C *** ERROR => Connect to database failed, rc=1, rcSQL=-10709

[dbhdbsql.cpp 347]

C SQLCODE : -10709

C SQLERRTEXT : Connection failed (RTE:[89006] System call 'connect' failed, rc=10060:A connection attempt failed be\

C cause the connected party did not properly respond after a period of time, or established connection\

C failed because connected host has failed to respond)

B ***LOG BV3=> severe db error -10709; work process is stopped [dbsh 1247]

B ***LOG BY2=> sql error -10709 performing CON [dblink 573]

B ***LOG BY0=> Connection failed (RTE:[89006] System call 'connect' failed, rc=10060:A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) [dblink 573]

M ***LOG R19=> ThDbConnect, db_connect ( DB-Connect 000256) [thDatabase.c 79]

M in_ThErrHandle: 1

M *** ERROR => ThInit: db_connect (step TH_INIT, thRc ERROR-DB-CONNECT_ERROR, action STOP_WP, level 1) [thxxhead.c 2392]

M

M Info for wp 0

M

M pid = 4832

M severity = 0

M status = 0

M stat = WP_NEW

M waiting_for = NO_WAITING

M workerType = DP_WORKER_DIAWP

M act_cs_count = 0

M csTrack = 0

M csTrackRwExcl = 0

M csTrackRwShrd = 0

M mode_cleaned_counter = 0

M control_flag = 0

M report = > <

M action = 0

M tab_name = > <

M

M ThIErrHandle: no current incoming request

HDBUSERSTORE info

hd1adm@usalvlhanadb.infor:/usr/sap/HD1/HDB00> hdbuserstore list

DATA FILE : /usr/sap/HD1/home/.hdb/usalvlhanadb.infor.com/SSFS_HDB.DAT

KEY DEFAULT

ENV : USALVLHANADB:30015

USER: SAPHD1

hd1adm@usalvlhanadb.infor:/usr/sap/HD1/HDB00>

Please find the attached log file zipped. And provide the solution.

Thanks for your help in advance.

Regards,

Krishna

Attachments

Logs.txt.zip (23.0 kB)