Skip to Content
author's profile photo Former Member
Former Member

How to keep cache local on HUB system , Static content should not be accessed from Backend al the time

Hello Masa/SAP Fiori team .

Is there a way to keep Static content local on gateway instead of loading static content each time from backend system ?

In our case read entity operation is taking longer . MYINBOX application is unified (connecting to two backend system) . Eg : I have 200 ITEMS to load from backend systems in my INBOX and each time read operation is taking around ~ 500 ms . I want to load /Read delta only from backend system not the full read/load each time user access INBOX .

I did test and deleted 120 items out of 200 loading of INBOX become faster however , this test was just to know read operation is issue or backend system performance .

Can you please guide me how we can keep METADATA CACHE local on HUB system instead of going to backend each time ?

-Suharsh

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Aug 31, 2015 at 05:12 AM

    Hi Suharsh,

    Please share the business scenario.

    What kind of documents should be approved and how many workitems will be received per day per approver.

    Please note that workitems are not static content.

    Metadata is cashed as default if you have not changed the configuration.

    Metadata Cache - SAP NetWeaver Gateway - SAP Library

    Regards,

    Masa / SAP Technology RIG

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Krishna Kishor Kammaje

      Krishna ,

      I do believe it is decent . However my user is looking for delightful experience .

      Keeping in mind 600 MS with ~50-80 items in INBOX this is still needs to be improved .

      My target is to remove the sniping wheel from navigation and loading time . I am working with many other SAP developers now to accomplish this .

      SOFT STATE is enabled in our case allready and i did this as a part of troubleshooting from config perspective . I do feel i wont keep this enabled for longer to save hardware resources on our system .

      Appreciate your input tho .

      Thanks .

      -Suharsh

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.