Skip to Content

Analysis for OLAP is not working well with OLAP Connections with language different of EN

Hi experts!

I have a problem very boring. I work with Analysis for OLAP over BW. My master data is in ES, so, I need to work with OLAP Connections with language ES saved. The problem is when I create a AOLAP document, de BEx used is not saved with the document. After to save, when I open the same document again, the BEx is asked.

For explain detailed, this is the steps of the problem:

Trying with EN

1) Create an OLAP Connection with BW and language Englis (United States), with the option Save language? checked:

2) By BI Launch Pad, create an new AOLAP document with the OLAP Connection TEST BW EN. For this example, I used the BEx query ZCCAL_O1 TENDENCIA VACACIONES, this query has a variable for country, is necessary has a variable. Save this document with name TEST EN:

3) Close the document TEST EN. Open again this document and the prompt window appears correctly. Select the country and click in OK.

This is the way expected, this is the working expected. But when I want to use a different language then EN...

Trying with ES (the problem)

1) Create an OLAP Connection with BW and language Spanish (Spain), with the option Save language? checked:

2) By BI Launch Pad, create an new AOLAP document with the OLAP Connection TEST BW ES. For this example, I used the BEx query ZCCAL_O1 TENDENCIA VACACIONES, this query has a variable for country, is necessary has a variable. Save this document with name TEST ES:

3) Close the document TEST ES. Open again this document and the problem appears: before the prompt window, other windows appears (Cube Browser) asking the source.

THIS IS THE PROBLEM!

- I've selected the source (BEx query ZCCAL_O1 TENDENCIA VACACIONES) when I created this document. Why this windows appears asking the source?

- Why this message "This component is not connected to the data source"?

- If I don't select a BEx query, nothing occurs, and I lost my document content.

- Is possible to select the BEx query ZCCAL_O1 TENDENCIA VACACIONES again, but is possible to select a total different BEx query.

In some months ago I created a discussion about this problem, but this problem wasn't so clear for me yet.

Analysis for OLAP is not saving with the BEx query

My environment is SAP BO 4.1 SP5 patch 6 (14.1.5.1698) and BW 7.0

I have some considerations after a lot of test done:

1) This problem is an environment's problem. I believe this problem is in the BO installation, is not in BW. Other consultant with a Virtual Machine with same BO did the same test connected with my BW and the problem didn't occurred.

2) If I don't select the box "Save language?", the AOLAP should take the language configured in BI Launch Pad preferences. This works ONLY if the language is EN, if the language still ES this problem still occurring.

3) Is necessary to use EN_en = English (United States), other EN languages like EN_uk = English (United Kingdom) doesn't works as well.

4) This problem occurs in my Productive and Develop environments.

I'm not so confident to install the SP6, because I installed the SP5 to try to solve but didn't solve.

So, experts, I'm considering to reinstall the environments, but this is the last option, because will create a lot of others bureaucratic problems. To do this, is necessary to be very confident that will solve the problem.

Thanks for every help!

Capturar1.PNG (33.6 kB)
Capturar2.PNG (80.2 kB)
Capturar3.PNG (105.2 kB)
CapturarA.PNG (34.6 kB)
CapturarB.PNG (82.0 kB)
CapturarC.PNG (68.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jan 15, 2016 at 05:40 PM

    Hi experts!

    I opened a incident on SAP Support to solve this problem. The problem was in the BW side. To solve was simple, was necessary to apply this notes:

    - BICS Java Note 1647346: https://css.wdf.sap.corp/sap/support/notes/1647346

    - ABAP Note 1646843: https://css.wdf.sap.corp/sap/support/notes/1646843

    I would like to thank everybody that answered my questions.

    Regards

    Gustavo Oliveira

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 28, 2015 at 09:01 PM

    Hi Gustavo

    You are seeing the list of cubes because, for whatever reason, the original query cannot be found.

    A few things to try to help narrow down the problem...

    1) Your current connection is to a BW system and users must then navigate themselves to the query. Please create two new connections direct to the ZCCAL_O1 TENDENCIA VACACIONES query.... one with the language set to English and the other with the language set to Spanish. Do these both work?

    2) Change the connections to use either prompted or pre-defined logons and not SSO. Do these both work?

    3) When you save the language as Spanish do you really want it so that the BI UI is in English, but the cube (meta)data is in Spanish? Would you not prefer everything to be Spanish? Create a new connection (this is important) but this time don't select any language and don't check the Save Language box. However, now change you BI Launchpad Preference to use Spanish. Does this now work?

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi friend Ian! Thanks for your attention again!

      This problem occurs with any BEx query, I used this BEx query for example.

      About your questions:

      1) This works, but this will create others bigger problems: I have a lot of developers BW/BO, and they create a lot of BEx query all the time, for the administration, I will have a several problems to create the connections for specific BEx query by development demand and to transport this from develop server to production server.

      2) To fix the user and password in the connection doesn't solve the problem. And this solution will create a other problem: I will lost the data security in BW.

      3) A 90% of my metadata is ES, the rest is EN. A 90% of my users are ES, the rest is PT and EN, however, that uses access data in ES and EN independent of they language. To fix the language in the BI Launch Pad properties solve problem partially because the most of my users is ES, but I have a lot of users ES that they Windows is EN. And for this solution works is necessary to uncheck "Save Language?" and set "Language" to EN, this cause other problem: Design Studio. DS doesn't consider the connection properties "Save language?" and the BI Launch Pad user preferences, the language of the connection is always what is defined in the connection properties "Language". After the SP5 is not possible to not set a Language, like a "Language Undefined". Before the SP5 this property is a text box, so is possible to type anything (blank), but after SP5 there is a combo box, and this combo box there is not a item like "Undefined".

      I'm 99% confidence of this problem is a BO environment problem:

      - I asked to a friends on the others companies to try reproduce the problem, and this problem doesn't occurs.

      - In some weeks ago I received a BO consultant of SAP Brasil, for a Quality Service Analysis on my environment. This consultant saw this problem and we did a test with his virtual machine with BO 4.1 SP5 Patch 6: the problem didn't occurred.

      I gonna try to install a new BO server from the begin and test this problem. however, I would like to fix my actual environment.

      Thanks a lot for your help!

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.