Skip to Content
0

SAP BPC 10.1 MS Problem with import with no Header row

Feb 02, 2017 at 08:48 AM

93

avatar image

I am having a problem importing a flat file with no header row. I am using a standard import package and running on BPC 10.1 MS

Transformation file

*OPTIONS
FORMAT = DELIMITED
HEADER =NO
DELIMITER = ;
SKIP =
SKIPIF =
AMOUNTDECIMALPOINT = ,
VALIDATERECORDS=YES
CREDITNEGATIVE=YES
MAXREJECTCOUNT= -1
ROUNDAMOUNT=

I am using a mapping section

*MAPPING
ACCOUNT=*COL(4)
etc

Has anybody experienced a similar problem? During validation I get an error:
Index was outside the bounds of the array.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Priyanka Jagtap Feb 02, 2017 at 09:14 AM
0

Can you show your flat file? try with DELIMITER = , and hopefully there are no special characters in the flat file...

Share
10 |10000 characters needed characters left characters exceeded
Ave Kang Feb 02, 2017 at 09:37 AM
0

Yes of course:

T2016.12 EK 000.000 A.12345.0 PJ.000000 PD.000 Block Unassigned TT.0 IC.0 T2016.12 EK 000.000 A.12345.0 PJ.000000 PD.000 Block Unassigned TT.0 IC.0 T2016.12 EK 000.000 A.12345.0 PJ.000000 PD.000 Block Unassigned TT.0 IC.0

I have tried validating with a header option YES and a header row and it works.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Please post the file in readable format.........or rather post a screenshot!

0
Ave Kang Feb 03, 2017 at 09:42 AM
0

Import file:

Transformation:

Data Preview:

Ave


capture.png (13.8 kB)
capture2.png (13.7 kB)
capture3.png (15.1 kB)
capture3.png (15.1 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

I can see spaces in ID's like "Block Unassigned". We cannot have spaces in between ID's. There are some special characters also which are not allowed. Look at the help for exceptions! "_" is most probably used instaed of a space in ID!

P.S You have really starnge ID's T2016.12, TT.0 etc.....

0
Ave Kang Feb 03, 2017 at 11:30 AM
0

I've tried with "_" and still get an error. Any more suggestions? I am really stuck.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Since its MS try using .txt file instead of .csv! and DELIMITER = ,(comma). Also remove the spaces after "=" in transformation file.

0