Skip to Content

Implicit enhancement done in include for one main program is not available in another main program

Hi mates,

When I'm adding an implicit enhancement in a standard include it is showing 6 main programs to select one from. So, i selected one and saved my enhancement. Now, when i run one Tcode it works fine as it involves the main program which i selected while saving the enhancement. But with other Tcode which uses another main program it gives error message as it does not find the code which i had written in the enhancement.

Earlier i used to think that if we make any enhancement in any include the code changes would be considered for all the main programs.

please suggest.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Aug 25, 2015 at 09:34 AM

    Read again documentation, look for implicit enhancement and framework program.

    The enhancement implementations for implicit enhancement options can only ever be appended to a single framework program

    Regards,

    Raymond

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.