Skip to Content
avatar image
Former Member

IDOC_METADATA_UNAVAILABLE in ECC SM58

Hi All,

We have 2 interfaces in place for IDoc to SOAP scenario in PI 7.31 using ICO.

While triggering the IDoc in first scenario in ECC, it is successfully reaching PI.

But when we trigger Idoc of second interface, it gets stuck in ECC 58 with Idoc_error_metadata_unavailable issue. the configuration for second idoc interface is exactly same as the first one. both are using the same Partner Number, Partner Type and Port.

Status of both the Idocs are green 03.

I have preloaded the Metadata of failing Idoc in NWA as well, and reimported Idoc in ESR again. But we are still encountering the same error.

Please provide pointers to resolve this issue.

Thanks and regards,

Ruchi Agarwal

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Aug 25, 2015 at 07:02 AM
    Add comment
    10|10000 characters needed characters exceeded

  • Aug 25, 2015 at 07:05 AM

    Hi Ruchi,

    My Few cents:

    1.Try to post / trigger the failing IDOC manually from WE19 and check

    2. In PI ensure that the IDOC structure is exactly the same that you are sending from Source (check if new segments are visible if its Z-Idoc)

    3. In PI IDOC Moni Delete the existing IDOC meta data for this failing IDOC

    4. Do not re-load Meta data manually therein...Once you trigger a fresh / new IDOC the Meta Data will get loaded automatically in 7.31

    5. Check if Cache is up to date

    Hope it helps

    Regards,
    Azhar

    Add comment
    10|10000 characters needed characters exceeded