Skip to Content

ESS / MSS Work feeds lane empty

Hi!
We are trying to implement the work feed lane, but we cant seem to get any information shown:

and there arent any feeds to choose from:

I have done the following customizing:

And we have added the following to the Role (through pfcg)

Besides this - i have also assigned the feeds directly to my user.

When i run the program:

( i have to run it by using the debugger - because it will only work in batch mode.)

but i can verify that the different BADI's gets called, and the text is correct - with upcomming birthdays - but i gives me an error:

the error is:

HRESS_BDAY_UPCOMING: XXUSER cannot be notified.

where XXUSER is my username...

Has anyone exeprienced anything like this?

We use a local gateway on our HR system.

br Ronn i

1.png (9.8 kB)
2.png (16.5 kB)
3.png (14.2 kB)
4.png (7.2 kB)
5.png (14.4 kB)
6.png (41.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    Aug 21, 2015 at 11:10 AM

    Hi Again! As of now - i think i have located where the problem is:

    as the screenshow shows - the system tries to figure out how to connecto the gateway.

    but this i localgateway - so it will not find any system:

    because we use the gateway on the same server (local gateway)

    am i missing out on something here? 😊

    i tried debugging in the above code - and if i change the statement to be OTHERS - then it will go in

    "DIRECT" mode - which actually works..

    so the question of course is how i make i go in direct mode everytime 😊


    10.png (101.2 kB)
    11.png (9.8 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Aug 18, 2015 at 11:44 PM

    http://scn.sap.com/thread/3464412 havent see this error yet, is all the configuration in place?

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Siddharth - i think we have done the configuration correctly.

      We are currently running our setup with a local GW only.

      So both the Renewal Packages and the GW functionality is on our HCM System.

      We have a central gw though, and when i debug - i can see that it looks like it has subscribed the users for both systems:

      But when i subscribe users - there is no selection of system as far as i can see?

      Also i found another "thing"

      The ODATA implementation for the Work Feeds - has a method for looking into subscribtion keys.

      /IWBEP/IF_MGW_APPL_SRV_RUNTIME~GET_ENTITYSET

      When debugging i came accros this "feature" in method

      *-Read User's role to retrieve the subscription keys he/she can use

      cl_hress_work_feed_utility=>read_personalization_key(

      EXPORTING

      * iv_personalization_key = 'HR_WORK_FEEDS'

      iv_username = lv_username

      IMPORTING

      et_subscription_key = lt_filter_subscription_keys ).


      When looking into this method it says:





      This basically looks at your asigned roles - and sorts away every NON composite roles - if you have at least 1 composite role.


      In our case the HR_Renewal role in play (ZCOMPANY_MSS_XX) is not a composite role - and i havent read anywhere that this was a requirement?



      Br Ronni

      7.png (30.6 kB)
      7.png (43.0 kB)
  • Aug 21, 2015 at 10:52 AM

    Hi Again!
    I just did som more error searching - and i think my error might be to our settings -not being correct.

    This is the error we get - when the notification is being sent:

    Also - it gives and error in the gateway log:

    But i cant seem to find any information regarding how to setup the quees for use with

    this?

    Has anyone else - configured this - using a local gw scenario?

    br Ronni


    8.png (66.8 kB)
    9.png (52.7 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Aug 24, 2015 at 06:19 AM

    Hi Siddarth!

    Thank you for helping.

    By debugging i found out that we needed a system alias for - even though we we only use the local gateway.

    But after creating a new system-alias, registrering it in the quee, and assigning it to the gateway alias - then everything started to work!

    😊

    br Ronni

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 24, 2015 at 07:47 AM

    This message was moderated.


    SAP ESS_MSS.jpg (315.5 kB)
    Add comment
    10|10000 characters needed characters exceeded