Skip to Content

'P' Icon Missing in Personas 3.0-SP1

Hello Experts,

Personas 'P' Icon is missing in my environment where we implemented the required components and Notes as listed below. Please suggest, Are we still missing anything.??

SAP_BASIS 740 SP0004

PERSONAS 300 SP0001

Kernel 742 with Support Pkg lvl : 200

**All SICF Services are Active for Personas.

**restgui has been set with CL_HTTP_EXT_ITS_BASIC in Handler List.

Checked in Both Firefox and chrome browsers.

User was assigned the following Roles.

/PERSONAS/ADMIN_ROLE

/PERSONAS/CONSUMER_ROLE

/PERSONAS/EDITOR_ROLE

and a Custom Role having Authorization Objects S_TCODE, P_ADMIN, P_EDIT, P_RUNTIME.

Personas Health Check:

Implemented SAP Notes:

All the notes from central Note 2175479 - SAP Screen Personas 3.0 SP01 : Released Notes Information

are not Implemented. Required Notes only Implemented as listed below.

Implemented Notes:

2179045 - Update of Client Sources Files

  • 1926394 - SAP GUI for HTML: Rendering mode update
  • 1995776 - ITS up/down: restgui dialogs instead of applet execution
  • 2016640 - Invalid GUI input data: display - window dimension conflict
  • 2076084 - Ghost Elements in SAP Screen Personas
  • 2148349 - SAP Screen Personas Call transaction variant
2187581 - Date: 2015-07-01 - SAP Screen Personas 3.0 SP01 : Minor corrections based on CuV feedback 2191155 - Date: 2015-07-13 - SAP Screen Personas 3.0 SP01 : Flavor Admin UI "Remove History" damages flavor (IMPORTANT) 2191624 - Data: 2015-07-13 - SAP Screen Personas 3.0 SP01 : Correction for theme assignment by role 2193721 - Date: 2015-07-17 - SAP Screen Personas 3.0 SP01 : Admin UI: Shortdump in case of missing authorization 2193821 - Date: 2015-07-17 - SAP Screen Personas 3.0 SP01 : Admin UI: Flavor translation screen shows all flavor versions 2187907 - Date: 2015-07-17 - SAP Screen Personas 3.0 SP01 : Editor shows incorrect url whitelist error message 2199000 - Date: 2015-07-31 - SAP Screen Personas 3.0 SP01 : Correction of flavor compression 2193145 - Date: 2015-08-03 - SAP Screen Personas 3.0 SP01 : Usage of special characters in icon id 2201594 - Date: 2015-08-04 - SAP Screen Personas 3.0 SP01 : Updates in Health Check Tool for Personas Client Note check 2051455 - Date: 2015-08-12 - SAP Screen Personas 3.0 : Screen and Control Overwrite Entries

Below Mentioned Notes from Central Notes 2175479 - SAP Screen Personas 3.0 SP01 : Released Notes Information are Not Implemented, Does it effect to load the Personas 'P' Icon??

Not Implemented:

  • 1777513 - WebGui LogOff does not work
  • 1969437 - SITSPMON does not show its profile parameters
  • 1970427 - SAP GUI for HTML: Rendering problems in Enterprise Portal (EP)
  • 1972793 - SAP GUI for HTML: Start service in SAP GUI for HTML: Screen with wrong size is displayed
  • 2009797 - ITS: Exceptions and short dumps are not displayed or are displayed incorrectly
  • 2049251 - Service handler for fuzzy/type-ahead search
  • 2072092 - Server crash when starting PERSONAS on AIX
  • 2111099 - SAP GUI for HTML: Deactivate domain relaxing
  • 2141004 - SAP GUI for HTML: HTML and JavaScript files cannot be loaded
  • 2137719 - Determination of font sizes by ITS plug-in
  • 2091386 - SAP GUI for HTML: HTML Viewer and determination of basis window name

Please let me know ASAP whether we are still missing any components/Notes to get the 'P' Icon visible.

Thanks.

pastedImage_0.png (22.1 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Aug 17, 2015 at 04:50 PM

    I'd first check why are there inactive objects... there shouldn't be any, so you need to fix that and re-test.

    Add a comment
    10|10000 characters needed characters exceeded

    • For the missing P: If you don't have inactive objects anymore in the Personas health check tool, then the problem may be caused by some other installation issue.

      You wrote that all necessary services are activated. Are the service parameters correct? I'd suggest going through the installation guide once again and make sure nothing is missing. If all else fails, create an OSS incident and provide access to your system.

      As for SPRO: Personas 3.0 doesn't have anything in the IMG, as opposed to Personas 2.0 so that's normal.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 15, 2015 at 04:35 AM

    I have the same problem but I follow note 2175479. My P icon is appeared but not in IE. It shows P in FF and Chrome. I guess it could be problem with IE compatible (see note 2050838).

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 26, 2016 at 03:46 PM

    We have the same issue .

    Personas 3.0 loads fine in Chrome.

    In Internet Explorer it logs me in - but gives me a blank screen.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.