Skip to Content

No Mock data when running App from FLP

Hi,

I have been able to register my App(created on Hana webide trial) on the trial FLP.

But the thing is that although I am able to run the App using Mock data from WebIDe, I am not able to run with mock data OR no mock data comes up if I run the App from Fiori LaunchPad. Any idea what step am I missing?

I have already configured project settings and Mock data settings.

Thanks,

Ags

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Posted on Mar 31, 2016 at 10:09 AM

    This is what I've done to make it working:

    1 - I created a new SAP Fiori Master-Detail application using the ES4 Public Gateway system. I used the GWSAMPLE_BASIC service: then I used the Products collection for the Master view and the SalesLineItemCollection for the Detail view

    2 - I had to remove the sorter from the Master.view.xml file from line 37 to 40 because this collection cannot be sorted on Name, but this should not influence this process

    3 - I removed all the Run Configurations just to be sure that it's using the new one

    4 - I tested the app in Web Preview by selecting the Component.js file and clicking on Run and it worked fine

    5 - Then I edited the Component.js file adding the code

    sap.ui.require([

    "com/test/mock/localService/mockserver"

    ], function (mockserver) {

    // set up test service for local testing

    mockserver.init();

    });

    just in between the string "this.getRouter().initialize();" and the "}" closing the init function. Pay attention that in the rquire function the path to the mock server must match the name of the namespace specified in the Component.js file.

    I saved the Component.js file

    6 - I executed again the Component.js file and now the application starts automatically with mock data

    7 - I deployed the app to the HANA Cloud Platform

    8 - When finished, I registered the app to SAP Fiori Launchpad by clicking on the "Register to SAP Fiori launchpad" button

    9 - When finished, I clicked on the link "Open the registered application"

    10 - The application works with mock data on the FLP

    The only issue I found is that, when I start again the application by using the direct link to it, the first time it asks me for the credentials to the real server. I just press "Cancel" and then "Retry" on the next error message and the mock data appear.

    Regards,

    Simmaco


    03.png (179.2 kB)
    04.png (211.3 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      You can configure a dummy service(say northwind service) and use that request url in place of "here/goes/your/serviceurl" in manifest.json.

      "ach": "ach",

      "resources": "resources.json",

      "dataSources": {

      "main": {

      "uri": "/northwind/V2/Northwind/Northwind.svc/",

      "type": "OData",

      "settings": {

      "odataVersion": "2.0",

      "localUri": "localService/metadata.xml"

      }

      },

      "Northwind.svc": {

      "uri": "/northwind/V2/Northwind/Northwind.svc/",

      "type": "OData",

      "settings": {

      "odataVersion": "2.0",

      "localUri": "localService/metadata.xml"

      }

      }

      },

      Regards,

      Vishnupriya

  • Posted on Nov 19, 2015 at 11:46 AM

    I have the exact same original issue... and the answer is not given yet 😔

    Background:


    1. Created Hana Cloud Platform Trial

    2. Enabled all services including SAP HANA Cloud Portal (needed for FLP)

    3. Use "WebIDE" to create an application

    a. chose "Sample application" > "Shop" (this creates a project "nw.epm.refapps.ext.shop")

    I can run it with MockData from the WebIDE when I choose to run it as WebApplication and choose: /webapp/test/testFLPService.html

    That works fine.

    Now for a demo I want to deploy this application to the HANA Cloud Platform and Register it in my HANA Cloud Portal > FLP page. WITH MockData as I don't have the resources to setup a real oData services now.

    I cannot understand why this isn't possible. If it works form the WebIDE when run as "WebApplication" why can it not work with MockData when it is deployed and registered in FLP?

    FYI everyone can recreate the issue just by using a trial and a copy of the demo app "Shop".

    Thanks in advance.

    B.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hi Jaime,

      yeah, pretty much.. you "add" all dependencies of MockServer (like sinon, etc) into your own project and instead of loading from the UI5 resources you load the one in your own namespace.

      reason for such is, it would appear there is some sort of issue going on, not on your own code but rather maybe a bug with the UI5 version you're using.. this would remove doubts as you're loading code you control.

      probably best to upgrade your UI5 library afterwards so you don't replicate files and versions everywhere - but as a workaround (and to test a solution) it should work.

      Cheers,

      Dan.

  • Posted on Aug 12, 2015 at 06:43 AM

    Please attach the Component.js of your application, it might need a small addition

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 13, 2015 at 08:32 AM

    Thinking from a different angle, is it an account specific limitation since I am having trial accounts for both my CLOUD as well as LOCAL Webide ??

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 19, 2015 at 03:53 AM

    Hi,

    I created a fresh new Kaspel App and did all the config/deployment so as to register it in my FLP.

    But now I am not able to run the APP itself in FLP. Below are the screen shots. Can anyone tell me where am I wrong?

    This is the response when I click my APP in FLP

    The strange thing is that if I am registering a NORMAL fiori App I can open it, but when its Kaspel App, I get this error.

    - Ags


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 25, 2016 at 10:18 AM

    Hey , Meni.

    I am struggling with the same problem. Could not present Fiori app in launch pad for customers as backend is not even accessible and mock data is not loaded in FLP case.

    Did you solve that somehow ?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 26, 2016 at 07:11 AM

    Hi, i also have the same Problem which I try to solve for hours now. I can deploy the App from WebIDE but when openin FLP no mockup data are shown,page is empty.

    Does any one have make this working? And how?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.