Skip to Content
0
Former Member
Aug 11, 2015 at 05:37 PM

NWDS and NWDI Handshake issue for SAP PO BPM development

61 Views

Hi,

We have installed SAP PO 7.4 SP11 (Single Stack) and NWDI. PO and NWDI are installed in separate host.

We have followed SCN documentHow to setup NWDI with CM Services and CTS+ for Process Orchestrationto setup NWDI and it appears OK.

After NWDI setup, we followed below steps

1) Created a new Software Component (Axx_P2PCONTRACT_BPM) in SLD of PO

2) Created following dependencies for the same Software component in PO SLD

  • MOIN BUILD TOOL 7.4
  • DI BUILD TOOL 7.40
  • ESCONF BUILD TOOL 7.40
  • BPEM CONTENT 7.40
  • COMPOSITION BUILD TOOL 7.40
  • BPEM-BUILDT 7.4

3) Imported this software component in NWDI

4) After the import in NWDI, we only see DI BUILD TOOL 7.40 as the only dependency.

5) From NWDS, logged to NWDI development configuration and imported the newly create Software component.

6) In NWDS created a new Netweave BPM process under this Software component, However, when i tried to build in NWDS, i am seeing following error.

Build failed for axx.com/p2pcon (axx.com_Axx_P2PCONTRACT_BPM) in variant "default": Illegal component usage: compartment "axx.com_Axx_P2PCONTRACT_BPM" does not use compartment "sap.com_BPEM-BUILDT" of used DC "sap.com/tc/bpem/bi/bp/buildtool"

Build failed for aol.com/p2pcon (axx.com_Axx_P2PCONTRACT_BPM) in variant "default": Check for used DCs failed: Illegal component usage: compartment "axx.com_Axx_P2PCONTRACT_BPM" does not use compartment "sap.com_BPEM-BUILDT" of used DC "sap.com/tc/bpem/bi/bp/buildtool"; using DC: com.sap.tc.devconf.internal.DCProxyMake@ee454

I am not sure why we are getting this error. Any help is appreciated.

Thanks

-Pradeep