Skip to Content
0

Work Manager 6.4 CATS Sync

Feb 02, 2017 at 12:41 AM

219

avatar image

transmit.jpgztransmit.jpgExperts,

I am working on a requirement where we want to separate Work Order sync from Crew Time sync. For this, I have created a copy of standard Transmit action and assigned it to the Crew Manager Transmit button. I have also removed CATS time sync action from standard Transmit action. However, when i sync the device from Work Order screen, I can still see that CATS record are getting transmitted eventhough i have removed cats sub action step.

Is there any other place from where the CATS records gets picked up during transmit apart from subactions in Transmit action?

transmit.jpg (67.2 kB)
ztransmit.jpg (79.8 kB)
10 |10000 characters needed characters left characters exceeded

Alok,

We agree with what Sudhir stated to create a different fetch and make it a non-main fetch. Please review the SAP Work Manager fetches (i.e. there are multiples of them). Some of them are not main fetches. Study how a particular button calls them out as a non-main fetch in their transmit steps. I voted Sudhir answers up.

Best Regards,

Mark Pe
SAP Product Support

1
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Bill Froelich
Feb 07, 2017 at 01:24 AM
0

Any applied transactions with backend steps are always sent to the server and processed at the start of the transmit. There is no facility to selectively send applied transactions. The only option would be to not generate the CATS transactions until you run your new CATS transmit step. This would be similar to what happens with Workorders where the transactions are generated at the start of the action before calling the transmit step.

This will be a fair amount of work to implement as it wasn't designed for this use case.

--Bill

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Bill.

This is exactly what i was looking for. Based on what you have mentioned above, I did following:

1. Created a copy of standard cats transaction.

2. Removed update and data steps from the copy transaction.

3. Created a copy of the cats edit transaction.

4. Create a copy of standard Transmit and assigned this to crew management tab.

5. Created a new subaction within this ZTransmit to call transaction Zcatsedit.

This worked for my usecase.

Thanks for the guidance.

0
Sudhir Lenka Feb 02, 2017 at 09:57 AM
1

Hi Alok,

You need to make the Time Sheet fetch as non main fetch by deselecting the main fetch check box in the fetch.

And you need to have another action having a Transmit step with linking to GetTimeSheet fetch.

You can't have a separate Transmit to send the Transactions to back-end, it's controlled by frame work.

Thanks,

Sudhir.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Mark/Sudhir,

I did as suggested: Made Time sheet fetch as non main fetch. Created a new sub action in Ztransmit action and linked this to GetTimesheet fetch. However, i still see that CATS time is being transmitted during normal sync. Is there any other place where agentry picks up the transaction from other than action and fetch?

0
Sravanthi Polu Feb 04, 2017 at 09:37 AM
0

Hi Alok,

Verify in Mobile Application Configuration->Client Global->"LabourTime.useCATS".By default it is set to "Y".Change this parameter to "N" and check if time sheets are update.

Thanks,

Sravanthi.


cp.jpg (71.3 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Sravanthi,

I haved changed LaborTime.useCATS to 'N', but i see that time record in Crew Manager are still getting transmitted.

My question is, in standard Trasmit action, which subaction transmit CATS record to server or is there any other place where this configuration is picked up from?

Appreciate your help.

0