Skip to Content

"Continue working without this add-on" error message in SAP 9.2 PL3

Hi Everybody!!!!

I got a problem, I found the solution, and I thought about sharing it.

* I recently installed SAP 9.2 PL3 in a Demo Environment
* I have two add-ons, "screen painter" and my own,
* SAP Client and Add-on software are all of them at 64 bits,
* Everything, including both add-ons, worked well BEFORE applying SAP license.

But, once I applied the license,
* SAP US Demo Company did not like the license due to Localization issues,
* I had to install the Demo Company of my country, which is Canada,
* License work well for the new Demo Company, but NONE OF THE ADD-ONS WORKED,
* Everytime I tried to any of these add-ons to the new Demo Company, i got the "Continue working without this add-on" error message.
* Adding, removing, allocating, setting starting parameters, setting starting mode per user resulted in the "Continue working without this add-on" error message.
* Tinkering with the file "AddOnsLocalRegistration.sbo" did not help either.
* Starting SAP B1 with Admin rights has no effect whatsoever.

So, this is what worked for me (thanks https://archive.sap.com/discussions/message/16578898#16578898 )

* On the new company, I deleted the records of the table OARI.
* Once I did that, I was able to re-assign both add-ons to the new demo company, and everything was great after that.

Of course, that is what worked for me, which is no guarantee that it will work for anybody else.

Manuel

PS: This posting has been posted "AS IS"

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Feb 02, 2017 at 01:57 AM

    Hi,

    Thanks for sharing solution with us. Better post as blog not as question type.

    Regards,

    Nagarajan

    Add comment
    10|10000 characters needed characters exceeded