Skip to Content
0
Former Member
Feb 01, 2006 at 09:21 PM

Secure FTP using FTPS (SSL/TLS) - need help!

133 Views

I am trying to use an FTP Sender Channel using Secure FTP. I am currently getting a "java.net.ConnectException: Connection timed out: connect" error.

I am on XI 3.0 with SP13.

Settings are FTPS (FTP Using SSL/TLS for Control and Data)

Command Order Auth TLS, USER, PASS, PBSZ, PROT.

I am able to connect from my pc using WSFTP Pro which looks to be using the same command order. I made sure WSFTP Pro was set for passive connections as XI only supports this until SP15.

I have asked our Basis support to make sure the proper ports are open that are used for the connection and file transfer. They have deployed the Java Cryptographic Toolkit on XID, and changed the startup mode for SSL runtime from 'manual' to 'always'. The site I will connect to uses a certificate from Equifax which was added to the TrustedCAs keystore view. After still not being able to get a file, I also added the certificate of the site, which I was able to export from WSFTP Pro and import onto XI with STRUST.

I have increased the J2EE trace for com.sap.aii.adapter.file to Debug, but I haven't been able to get much out of the log. I see entries, such as some SSL activity and the timeout, but nothing that points me to an answer. Of course, I really don't know what to look for.

I have tried to connect to the remote server by name or ip with the same connection timeout.

I currently don't have it set to use X.509 certificate for Client Auth, but I did try a few of those options with no luck.

Any pointers would be appreciated.

Thanks,

Eric Peterson