Skip to Content

Batch in SAP Gateway

Hi Experts

I am implementing batch operation but it is giving empty response.

Carriage return are maintained properly as per note.

Both /IWBEP/IF_MGW_APPL_SRV_RUNTIME~CHANGESET_BEGIN &/IWBEP/IF_MGW_APPL_SRV_RUNTIME~CHANGESET_END are redefined.

Version of Gateway 2.0 SP15

Please suggest.

Regards

Manish

batch.png (46.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Feb 01, 2017 at 07:40 PM

    Hi Manish,

    From basic inspection it does look like you are missing the closing boundary for batch. You can reference this blog as an example - I couldn't find the original one I referenced when trying out batch operations. Batch Operations Blog

    Regards,

    Ryan Crosby

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 01, 2017 at 06:31 PM

    Hi Manish,

    If you set a breakpoint in the begin method and execute this test does it initiate the debugger? If it does not, then there is some format issue potentially with your request. If it does then you would want to debug your read operations to see if the response is constructed properly.

    Regards,

    Ryan Crosby

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 01, 2017 at 08:48 PM

    Thanks for the help Ryan.

    It was closing of boundary of batch.

    Regards

    Manish

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 11, 2017 at 04:37 PM

    Thanks for the help Ryan.

    It was closing of boundary of batch.

    Regards

    Manish

    Add comment
    10|10000 characters needed characters exceeded