Skip to Content

Hiding the Timesheet tab in SAP Work Manager 6.2

Hi,

What is the best and recommended way to hide/disable the timesheet tab from the SAP Work Manager App 6.2. I have already tried the Syclo Config panel and changed the global parameter value for LaborTime.useCATS to N. It dint hide the timesheet tab on the app.

Thanks,

Yomesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Aug 03, 2015 at 04:30 AM

    Yomesh,

    Depending on the device platform, you will want to set the Wo.UseLaborReporting = N in the config panel and the Timesheet tab will be automatically hidden.  This would be for iPad, Android and WPF clients.  If you are using PPC you will need to set the LaborTime.useCATS.

    I recommend checking the enable rules for the screens in the editor to confirm which config panel value it is looking at.  Also, remember to restart your SMP server after changing the value in the config panel to pickup the new change.

    --Bill

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 29, 2015 at 07:17 PM

    Yomesh,

    If you want to hide something on the device you will need to use the Agentry Eclipse Editor to disable or hide the screen.

    Find the screen you want and you can disable it. Normally people can write rules to make it smarter like if a particular person logs in to enable it while others to disable it.

    To simply disable it just choose disable.

    After you change it publish the changes and produce a new zip file to be loaded to the SMP 3.0 cockpit.

    Hope this helps you out.

    Regards,

    Mark Pe
    SAP Platinum Support Engineer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      The config setting allows you to configure use of either IW41 or CATS. These options are mutually exclusive.

      To completely disable the screen you must use the rule as Mark suggested.

      thanks,

      Chandra

  • Aug 03, 2015 at 06:17 PM

    Hi All,

    Thanks for your Help !! I have done it using LaborTime.useCATS for now. The only thing I had to do in  addition to what I already did was to reset the WPF client. The WPF client Transmit was not working because of which it was not loading the config changes from backend ECC config. I had to reset it and then again load it.

    Thanks,

    Yomesh

    Add comment
    10|10000 characters needed characters exceeded