Skip to Content

SAP Work Manager 6.2 - Work Order notifications not updating to ECC

Hi All,

Currently I am working on SWM 6.2 app.I have customized the notifications functionality on top of standard functionality.

I have enabled the work order notifications edit functionality in the app. Mapped required "Notification Post Steplet, Stephandler, BAPI & Classes in config panel.

When I edit the downloaded notification in device from the work order detail screen, the notifications are editable and they are getting saved in device.

But when I try to update the edited information to ECC,no steplets are being executed during the transmit and the changes were still existed in the device.

There seems no issue with the standalone notifications, the edited information on standalone notifications are successfully updating into ECC.

When I am editing the work order notifications in device, I could observe the below.

  1. Navigating to work order notification screen from work order detail screen
  2. Edit the notifications from notifications detail screen
  3. Edited notifications were saved successfully in notification list screen and could able to see the "*" symbol which indicates information need to be updated. But the work order list screen is not displaying any "*" symbol.

App: SAP Work Manager 6.2

Device: iPad (iOS8)

Platform : SMP 3.0

Kindly suggest me to resolve it.

Thanks & Regards,

Roopa.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 30, 2015 at 02:09 PM

    Please make sure the following 2 fields of the Notification Object are updated during the edits

    1) IsEdited

    2) NeedsXmit

    The rule that triggers PostNotification action on the Transmit Action looks at these 2 fields.

    thanks

    Chandra

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 27, 2015 at 09:43 PM

    Roopa,

    With your statement "But when I try to update the edited information to ECC,no steplets are being executed during the transmit and the changes were still existed in the device."

    Need to check your transaction update step if it has some steplets listed in it.

    Try to use the Agentry Test Environment to debug your transaction. Check before, during and after apply. Set breakpoints.

    With your other statement "But the work order list screen is not displaying any "*" symbol." There is a rule tied to that * in the Agentry editor. Study the rule and this will give you some idea on why it is not firing for you.

    With the two steps above, hopefully you can debug and find the reason why it is not functioning.

    Hope this helps,

    Mark Pe
    SAP Platinum Support Engineer

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 28, 2015 at 08:49 AM

    Hi Roopa,

    I implemented the same change time ago and that's what I did after allowing the edition of work order notification:

    - Added a new subaction step in the WorkOrderPost action executed during transmit, the new subaction step is called something like WorkOrderHeaderNotificationPost and it comes after ComponentsIssue but before the WorkOrdersPostCurrentOrLocal

    - In my scenario, I only enabled the edition of the notification directly linked to the work order, not the rest. So this subaction step is not a loop, it selects only the notification where the ID is equal to Workorder-NotifNum. If you allow the edition of all the work order notifications then you will have to loop over the collection.

    - The subaction step has an execution rule that checks if the notification NeedsXmit field is true

    - The subaction step calls a new custom action which is basically a copy of NotificationPostCurrent. I think you could actually reuse NotificationPostCurrent, I'm don't remember why I created a new action since it is using the same transaction.

    Add comment
    10|10000 characters needed characters exceeded