Skip to Content
author's profile photo Former Member
Former Member

ERROR IN SMQ2 OF ECC SYSTEM " FUNCTION MODULE NOT FOUND" REG....

Hi All,

I have created an Inbound delivery in ECC against a purchase order through VL31N.

Delivery sent to WMS system but not visible .

SMQ1 does not contain any outbound queue related to my delivery in ECC.

SMQ2 does not contain any Inbound delivery related to my queue in EWM.

I found my queues in SMQ2 in ECC system(i am still wondering why?)

In error log i see "System Fail" with status text Function module "" not found.

Please help me to resolve the same.

Thank you

VIJAY

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 15, 2015 at 06:40 AM

    Dear All,

    First of all sorry for the delay for some network issues.

    The issue was resolved by me

    Thank you all for your kind support

    Best regards.

    VIJAY

    Add a comment
    10|10000 characters needed characters exceeded

    • Dear Vijay,

      i have actually the same problem.

      Maybe you can tell me how you solved the Problem.

      Best Regards Manuel

      Problem is solved.

      It happed because InboundDelivery.SaveReplica and OutboundDelivery.SaveReplica existet in twice distribution models for the same warehousenumber.

      Message was edited by: Manuel Schmitt

  • author's profile photo Former Member
    Former Member
    Posted on Jul 10, 2015 at 08:20 AM

    HI Vijay,

    Have you created Distribution Model for your ERP WM warehouse which is linked to EWM warehouse in integrations settings in ECC:

    ERP-SPRO-Integration with Other SAP.Com Components-EWM-Basic Settings for EWM Linkage-Generate Distribution Model from ERP to EWM

    Regards
    Anoop


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 11, 2015 at 08:49 AM

    Hi,

    it looks like your qRFC call has wrong recipient.

    First cross-verify what Anoop suggests. In Tcode BD64 check if the EWM system is the recipient in the distribution model.

    You may also cross-verify whether the name of logical system is correctly assigned to the client and RFC destination has correct address.

    Does it help? If not please provide more details.

    Regards,

    Petr

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 12, 2015 at 11:13 PM

    Hi Vijay

    First create distribution model and create new del and check do you face same issue.

    Tcode >> /SPE/OL19 >>

    here system will take program to send del to EWM.

    check BD64 >> Program are there for your ECC WH >>

    check >>

    ERP SPRO>> Integration with Other SAP Components>>Extended Warehouse Management>> and Maintain Extended WM-Specific Parameters >> as extended

    why your issue is coming>>

    flow is Pur order >>del >> ECC WH no >check does it is extended wh > check distribution model>> take program and send to ewm (logical system)..

    in your case Pur order >>del >> ECC WH no >check does it is extended wh ( check this one )> check distribution model ( check this one ) >> take program and send to ewm (logical system)..

    create new documents and check it should flow if all is good. or you should get queue in smq1 not in smq2

    Regards

    Suraj


    pastedImage_1.png (19.0 kB)
    pastedImage_2.png (19.2 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 13, 2015 at 10:25 PM

    Hi Vijay

    If issue is resolved please close the thread.

    Regards

    Suraj

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.