Skip to Content

When debugging on HCP from Eclipse, I only see bytecode

I'm deploying a Java application on HCP (neo.ondemand.com), with a Java Web Tomcat 7 runtime, from Eclipse 4.3.2 with SAP HANA Cloud Platform Tools for Java 1.48.0.

I set a breakpoint in my application before starting it in Debug on the Server in Eclipse.

When the debugger stops, I only see Java bytecode, and the class appears somewhat renamed: the source shows a class name ...DiagramReader (from the bytecode), but the tab name is DiagramReader.0101

How can I debug with the source?

Thanks.

pascal.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Oct 22, 2015 at 07:28 AM

    Hi Pascal,

    Somehow the debugger cannot located the source files. Under the "Debug" window right-click on a line with one of your source classes and choose "Edit Source Lookup...". Then add your workspace's "src" folder. This should fix the issue.

    Best,

    Mustafa.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 10, 2015 at 02:29 AM

    Hello ,

    Please refer below threads ,may this fix your issue

    Troubleshooting Java Applications on SAP HANA Cloud Platform

    help --> SAP HANA Cloud Platform

    BR,Gowrisankar`

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.