Skip to Content
0
Jul 09, 2015 at 10:12 AM

Error : Communication between PI 7.4 (JMS adapter) and Apache ActiveMQ (5.11.1)

174 Views

Hello Experts,

We are trying to build communication between PI 7.4 (JMS adapter) and Apache ActiveMQ (5.11.1), but getting following error,

Error : A channel error occurred. Detailed error (if any) : java.lang.UnsupportedClassVersionError: org/apache/activemq/ActiveMQConnectionFactory : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
...


We have deployed drivers and added all the additional parameters as per below blog,


PI/XI: ActiveMQ - free but yet powerful JMS provider


Please help us to resolve this issue.



Thanks and Regards,

Prathamesh Dixit