Skip to Content

Proxy pointing to different client in ecc

Hi Experts,

I am facing a issue in synchronous interface. I configured receiver proxy communication channel defined url in that and maintain the user logon details for a client.

While testing my interface it is passing the messages to different client. I tested the url in browser it is pointing to another client.

Can you please provide me solution for this. Why i am getting this error?

Please any one provide me inputs to this.

Regards,

Suhale Shaik.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Jul 06, 2015 at 03:35 AM

    Hi Suhale,

    In the receiver CC there is an option to key in the Logon Client. Can you check that?

    If this does not help then I believe you need to provide the correct URL value of the corresponding Client. Basis should have this URL.

    Hope it helps.

    Regards,
    Azhar

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 06, 2015 at 09:27 AM

    HI Suhale,

    Can you let us know the PI version you are working upon.

    Please maintain the correct url and log on details of the client to which PI needs to send the data.

    Please share the screen shot of the proxy channel that you have configured.

    Regards

    Vishnu

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Suhale Shaik

      HI Suhale,

      I assume you have maintained the target url in the below format:

      http://hostname:port/sap/xi/engine?type=entry

      where hostname & port you can get from SMICM tcode-->press Shift+F1.

      Please make sure that you have maintained the correct client to which you want to send the data.

      Can you tell us whether this channel has previously has other parameters like other client details where currently data is going to.

      If yes, then the issue is related to cache. Please check on this.

      For workaround, you can just do copy object of this proxy channel and use it in the ICO object.

      Regards

      Vishnu

  • Jul 06, 2015 at 09:49 AM

    Hi Suhale,

    If you have used this channel before, may be the old client data is cached. Try to do a dummy change like changing descriptio, to do a CPA cache refresh or to recreate the channel.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Suhale Shaik

      Can you check in the outcome, to which url is it saying successfully connected to.

      If it is a old client url, then please recreate the channel with the required ECC system parameters and check the outcome.

      Regards

      Vishnu

  • Jul 06, 2015 at 03:34 PM

    Hi Experts,

    The problem is solved. The configuration URL Provided in Business system is the wrong one.

    I corrected it and the interface works fine now.

    Regards,

    Suhale Shaik.

    Add comment
    10|10000 characters needed characters exceeded