Skip to Content
author's profile photo Former Member
Former Member

E-Recruiting: Missing Obj.Relationships CP BP & NA in HRP1001 for User ID

Hi Experts,

I’m in support project and new to E-Rec.

We are facing strange (to me) issue to some users in E-Rec. When external candidate is registering, they are getting the error saying this user id is already assigned. The same error they are getting even if they try with different combinations at the same time.

When we check at the backend as per the received erroneous usernames (alias), those usernames are already created in the backend, which means working perfect.

But there are no NA, BP and CP mappings in HRP1001 for those usernames. And these usernames are created in an interval of 1min. We came to know that there are n no ‘of such cases.

We are not able to replicate this kind of scenario unless if we exit the debugger after user creation method and could not able to think out of box for replicating the issue

.

Please help.

Thanks in Advance.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Jul 01, 2015 at 06:22 AM

    Hi,

    What objects are created then? Only the user (SU01)? Executing CL_HRRCF_CANDIDATE => GET() with this userID shows an error?

    Regards,

    Nicole

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      ➖taking my comments back on Filled,Delete and Clone. Took time to understand the system.

      User ID creation and deletion is not happening at same time due to buffer.

      Initially it created User ID, then we bypassed to delete user id method with some dummy error.

      From the below screenshot there is already status for user id as 'N'(new), so the status did not changed to 'X'(Delete).

      If the entry is there in I_USZBVSYS table it is deleting in the method from the below screenshot.

  • author's profile photo Former Member
    Former Member
    Posted on Aug 01, 2015 at 05:03 PM

    Hi

    We encountered similar issue - In case user creation is failed in CUA due to some error then system proceed to create the user locally in E-Rec system and error message in internal table still exist.

    Due to error message existed in internal table because of CUA - system stop further processing of candidate creation CP, BP and NA and user created in local system remain as it is.

    Please can you let us know also if there is a standard solution for this.

    Thanks

    Sandeep

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 23, 2015 at 09:40 AM

    Finally SAP came back on the issue saying there are password policies mismatch from CUA and External System. This caused user id creation in Child system and not in Central System.

    Due to errors in the internal table from the CUA remaining objects are not created.

    Thanks everyone for your valuable inputs.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.