Skip to Content
0
Jun 24, 2015 at 11:59 AM

DBA Cockpit SAP Configuration Check failed

2766 Views

Hi All,

We have SYBASE ASE 15.7.0.131 in our ECC 6.0 system (SAP_BASIS 740 SP 9). I tried to perform the Configuration Check in DBA Cockpit, but it failed with the error "Required data collector Tables is not set up properly"

The following 2 errors are seen from DBA Cockpit:

  • [ASE Error SQL2812][SAP][ASE ODBC Driver][Adaptive Server Enterprise]Stored procedure 'saptools..SP_ADM_CONFIGCHECK' not found.
  • [ASE Error SQL208:42000][SAP][ASE ODBC Driver][Adaptive Server Enterprise]saptools..CFGCHK_RULEBOOK not found.

In DBA Cockpit Self-Monitoring, there are errors as in the following screenshot:

The errors related to some corresponding tables which does not exist. One of the warning showed "Table DBH_SNAP_TABLES: Column 'NumLevel0Waiters' does not exist". Another warning is "Another version of procedure 'saptools..SP_DBH_FWK_CLEANUP' found!"

In addition, when I tried to dump a database in DBA Cockpit, the dump failed due to the following error "Stored procedure 'saptools.dbo.SP_ADM_DUMPDB' not found". It seems that there is something wrong with the database saptools, but I could not find any thing in DBACOCKPIT error log.

We have implemented the following notes, but they did not solve the problems:

  • 2170712 (SYB: DBACOCKPIT, Various Fixes for SAP Configuration Check) in both the managed system (ECC) and the managing system (Solution Manager).
  • 1558958 (SYB: DBA Cockpit Correction Collection SAP Basis 7.02..) in Solution Manager
  • 1882376 (SYB: DBA Cockpit Correction Collection SAP Basis 7.40) in the ECC System.

What should I do to troubleshoot those errors?

I would be very grateful for any contribution.

Best regards,

Duy