Skip to Content
avatar image
Former Member

Receiver File error

I have FCC att receiver side

I have nodes with multiple fields

DT_ABC

      Node1

          A

          B

          C

          D

     Node2

          D

          E

          F

structure goes like that

they don't want field separatr

they want to assign 20 spaces for A, 15 for B, 10 for C and 15 for D

problem is when i gave field fixedlength, A has a value that obtain only 10 spaces..remaining ten are blank, same with B five spaces are blank

how do I meeet this requirement without using fieldseparator

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    Jun 22, 2015 at 07:47 AM

    Hi Midhun,

    You can achieve it using NameA.fieldFixedLengths

    NameA.fieldFixedLengths

    Specify a character string containing a list of fixed column widths that are separated by commas and determine the number and the length of columns generated in the text file. If you do not make any entries for NameA.fieldSeparator, the entry NameA.fieldFixedLengths is mandatory.


    Can you give screenshot of your FCC config.


    Regards,

    Azhar

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 22, 2015 at 08:50 AM

    Hi Midhun,

    they want to assign 20 spaces for A, 15 for B, 10 for C and 15 for D

    problem is when i gave field fixedlength, A has a value that obtain only 10 spaces..remaining ten are blank, same with B five spaces are blank

    how do I meeet this requirement without using fieldseparator

    You were saying that you have given fieldFixedLength. What is your requirement exactly?

    you need to use parameters like this.

    Node1.fieldFixedLength   20,15,10,15

    Node1.endSeparator        'nl'

    Like this for Node2.

    Did you use same like this?

    Refer this

    Converting XML in the Receiver File/FTP Adapter to Text Format - Configuring the File/FTP Adapter in Integration Directo…

    Regards,

    Suhale Shaik.

    Message was edited by: Suhale Shaik

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 22, 2015 at 09:00 AM

    Hello Midhun ,

    Your requirement seems to like the field Length is not fixed .

    So , If you want to assign spaces excluding the Length of the field value , you will have to achieve it through Message Mapping  .

    Regards,

    Malini

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 22, 2015 at 09:00 AM

    Hello Midhun ,

    Your requirement seems to like the field Length is not fixed .

    So , If you want to assign spaces excluding the Length of the field value , you will have to achieve it through Message Mapping  .

    Regards,

    Malini

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 22, 2015 at 09:20 AM

    Hi Midhun,

    If you are using fieldFixedLength as the FCC parameter, then I echo with out colleagues that you need to handle this spaces you are talking about at mapping level itself.

    For example, for A, you need 20 spaces, then in mapping level, append the spaces accordingly and map to the target. And in the FCC level, you need to mention the length of A as normal possible length + 20. Since when the message comes to the adapter level, A will have its actual value plus 20 spaces.

    Check this and let me know if you still having issues.

    Regards

    Vishnu

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 22, 2015 at 10:22 AM

    Hi Midhun,

    As per your requirement you should know the length of the field values that are coming from source and according to that you add the extra length of the spaces to that field in fieldFixedLength parameter.

    For example If A's data length is 10 and you want to add 20 spaces addition to that length then you need to define 30 as length in your channel.

    Like that you define B,C,D  values.

    Regards,

    Suhale Shaik.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I have done the same.

      I know the field length is 20. I get ten chaarcaters and I added ten spaces but stil I am getingerror in FCC

  • avatar image
    Former Member
    Jun 22, 2015 at 11:22 AM

    Hello Midhun ,

    Your requirement seems to like the field Length is not fixed .

    So , If you want to assign spaces excluding the Length of the field value , you will have to achieve it through Message Mapping  .

    Regards,

    Malini

    Add comment
    10|10000 characters needed characters exceeded