Skip to Content
avatar image
Former Member

Multiple users access request

Hello Gurus,

We have GRC10.1/07.

I have struck up with some issues

1. Multiple users access request - All users get same email with only one user details

2. Existing assignment for users - Approver cannot see composite role/business roles in existing assignment tab for users while approving request

3. User default parameters - After request completion users are not assigned with default parameters (maintained parameters in User Defaults)

4.  User Access Review - We have implemented UAR and it does not show composite roles for user

Please help me in resolving these issues.

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jun 17, 2015 at 02:17 PM

    Hello Vijay,

    2. Existing assignment for users - Approver cannot see composite role/business roles in existing assignment tab for users while approving request

    Check these SAP Notes for solution for the above Issue


    2123941

    2105072

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      1. Multiple users access request - All users get same email with only one user details

      Need to implement BADI,check Note 1727135

      2150192 - UAM:Notification for a multi user request not sent correctly

      1727135 - UAM:Notification for a multi user request not sent correctly


      3. User default parameters - After request completion users are not assigned with default parameters (maintained parameters in User Defaults)


      I assume you have followed the below link and configured user defaults,cross check all settings


      User Defaults - GRC 10.0


      if every thing is correct then check below settings


      In  SPRO -> Governance, Risk and Compliance -> Access Control -> User Provisioning -> Maintain User Defaults, the user defaults are not provisioned because the Target Connector is entered in mixed case rather than F4 selection (which should be upper case).


      4.  User Access Review - We have implemented UAR and it does not show composite roles for user


      Check tables.


      (1)Gracrolestatus (2) Gracrole (3)Gracrlconn (4)GRACPROFILE (5)Gracroleapprvr (6)Gracroleact (7)Gracrolerelat (8)Gracrolefa (9)Gracroleorgfld (10)Gracrolet (11)gracuserrole (12)gracroleusage (13)Gractaskexecstmp (taskname, connector)


      Execute once again Role usage job and then run the below UAR jobs

      1. GRAC_UAR_REQUEST_GEN
      2. GRAC_UAR_UPDATE_WORKFLOW



      Regards

      Baithi




  • Jun 17, 2015 at 03:20 PM

    Dear Vijay,

    regarding your questions:

    2. Existing assignment is not applicable for multiple users. This is only enabled for single users.

    3. Does default parameters work for single user requests? Make sure you have not restricted for a request type. Also check if "User Defaults" action is defined in the used request type for multiple user requests.

    4. This should definitely work with on your SP level. Make sure you have successfully ran all sync jobs in order to start the UAR workflow.

    Cheers,

    Alessandro

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Alessandro,

      This is not working for single user as well.

      I have maintained parameter values in User Defaults but no use.

  • Jun 19, 2015 at 12:49 PM

    G'Day Guys,

    I've got an issue with Multi User Request, so thought I'll just tag it along considering a similar issue is being discussed here.

    My query is, when we use this functionality for some reason it is changing all of the user’s country and user group to the first user on the request. Is this standard behavior or is there something that can be done to rectify this issue?

    Regards,

    Leo..

    Add comment
    10|10000 characters needed characters exceeded