Skip to Content
avatar image
Former Member

Variable screen doesn't popup in BEx Web

Hi experts

I have followed this blog:

http://scn.sap.com/thread/3315941

We are using a BEx variable, input enabled, not mandatory on a hierarchy.

In BEx Analyzer we get the variable input prompt.

In BEx Web not.

If you add the parameter &VARIABLE_SCREEN=X to the end of the URL it works.

But we need to add this parameter somewhere in the properties area for the iView.

Which parameter in the properties area needs to get adjusted with &VARIABLE_SCREEN=X ?

Thanks

T.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 05, 2015 at 07:37 AM

    Hi,

    I think you have upgraded the system.

    Please check the below link for details:

    Customer specific adjusting of BEx web-based variable screen

    Thanks & Regards,

    Chandra Sekhar.

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 05, 2015 at 10:06 AM

    Hi Thomas,

    Have a look at sap note 1671767 - BEX Variable Screen not showing via portal

    hope it helps.

    Regards,

    Vengal.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      Please check whether the following explanation helps you:

      I. Variable screen not shown by default scenarios:

      1. If a Query has no variables, no variable screen will be shown in web.
      It is not at all possible to see variable screen in this case.

      2. If a Query has variables (only optional variables but no mandatory
      variables ) then variable screen will not be shown.

      3. If a Query has mandatory variable but if it is prefilled, then variable screen will not be shown.

      You can enforce to see variable screen only in case 2 and 3 by using the
      parameter '&VARIABLE_SCREEN=X' to the end of URL of the relevant Query or the relevant Web Template.

      The variable screen would not be shown if there are no mandatory variables
      in the Query.  You can force it with the following methods:
      1) Append the parameter '&VARIABLE_SCREEN=X' to the links in your menu.


      2) Change the parameter in the web template used   > template property
         'Force variable screen' in the Web Application Designer, per
         default it is not checked.


      3) In case, no Template is specified, the standard Web Template is
         used   > transaction SPRO. In case, no Web Template is maintained as
         standard Web Template in transaction SPRO the Standard Web Template
         delivered by SAP is used. It is recommended not to change
         the original SAP Template but to create a copy, apply changes and
         maintain it as new Standard Web Template in transaction SPRO. Please
         review the following SAP Note:


         643464 - Activating the variable screen in the standard Web template


      II. Variable screen shown by default scenarios:

      Only when there is a mandatory variable which is not filled and has
      to be filled only by user via F4 help, then variable screen will be shown automatically.

      III. Please note that you should not make any changes in the Standard / Default Web Template          0ANALYSIS_PATTERN

      Thanks & Regards,

      Sapna

  • avatar image
    Former Member
    Jun 05, 2015 at 08:25 AM

    Hi,

    You need to maintain the variable screen show pop in the default web-template.

    This will then be used for all the queries or views.

    If you are using the web-template then you can directly do it by following the below SCN document.

    If you are doing if for the query/views, in such case you will first need to goto transaction code

    RSCUSTV27.

    Check in RSCUSTV27 for field "Ad hoc analysis" what value is maintained.

    If Ad hoc analysis field is blank, then it means default used template is "0analysis_pattern".

    Please follow below SCN document which talks about how to suppress variable screen.

    But you need do the reverse to bring the variable screens pop-up.

    Check the check box in default template regarding the web-template.

    http://scn.sap.com/docs/DOC-58884

    Regards,

    Amit

    Add comment
    10|10000 characters needed characters exceeded