Skip to Content
avatar image
Former Member

Issues in configuring kerberos for SAP HANA system

Hi Guys

I am configuring the kerberos on my SAP HANA system for the SSO configuration of the single domain controller and client logins using the Active Directory concept.

We have configured the kerberos using the document.

http://help.sap.com/hana_one/SAP_HANA_One_Security_Guide_for_AWS_en.pdf

All the steps were followed properly and no issues found in configuration, the krb5.conf file has been configured properly with the domain names and realms. After all the proper configuration while connecting the HANA database on client system configured by Active DIrectory we are facing the connectivity issue. Please find the below error.

hanaserver:/usr/sap/OVD/HDB00> hdbsql -i 00 -n myhdbserver@MYDOMAIN.COM

Welcome to the SAP HANA Database interactive terminal.

Type: \h for help with commands

\q to quit

hdbsql=> /c

Password:* -10709: Connection failed (RTE:[89001] Cannot resolve host

name 'myhdbserver@MYDOMAIN.COM' rc=-2: Name or service not known)

hdbsql=> \c

Password:* -10709: Connection failed (RTE:[-1] Kerberos error. Major:

"unspecified [851968]", minor: "No credentials cache found

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 03, 2015 at 08:50 AM

    Hi Somayya,

    Can you please confirm if you came across a solution to this error after completing the SSO setup for HANA?

    Sunil

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sunil

      Yes !!

      The problem is solved the issue was with the host name, the defined host name and the AD was not in the sync it was resolved when we updated the proper host name with IP reverse resolution in AD.

      Regards

      Somayya

  • Jan 08, 2016 at 09:51 PM

    Hi Somayya,

    I'm currently receiving the same error you have listed -10709: Connection failed (RTE:[-1] Kerberos error. Major:

    "unspecified [851968]", minor: "No credentials cache found but I don't have Kerberos or AD SSO Configured for our HANA System. Do you know what could cause the error to show in my case?


    Thanks,

    Andrew Johnson


    Add comment
    10|10000 characters needed characters exceeded