Skip to Content
0
Former Member
May 28, 2015 at 12:59 PM

suddenly getting "Error initializing storage" when trying to start ESP Studio

2912 Views

I have been running ESP Studio successfully for months. Recently started working with SDK, writing java adapters. That has been working well for a couple of weeks. Suddenly, I can no longer start Studio. I get a popup box (on Linux) saying "An error has occurred. See log file null." (what is log file null?). Then I get the stack trace:

esp@hpux:/opt/sybase/ESP-5_1/studio$ streamingstudio

java.lang.RuntimeException: Error initializing storage.

at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:77)

at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)

at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:297)

at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:232)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:606)

at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)

at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)

at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

at org.eclipse.equinox.launcher.Main.main(Main.java:1438)

Caused by: java.io.FileNotFoundException: /opt/sybase/ESP-5_1/studio/configuration/org.eclipse.osgi/.manager/.fileTableLock (Permission denied)

at java.io.RandomAccessFile.open(Native Method)

at java.io.RandomAccessFile.<init>(RandomAccessFile.java:241)

at org.eclipse.osgi.internal.location.Locker_JavaNio.lock(Locker_JavaNio.java:36)

at org.eclipse.osgi.storagemanager.StorageManager.lock(StorageManager.java:388)

at org.eclipse.osgi.storagemanager.StorageManager.open(StorageManager.java:701)

at org.eclipse.osgi.storage.Storage.getChildStorageManager(Storage.java:1747)

at org.eclipse.osgi.storage.Storage.getInfoInputStream(Storage.java:1764)

at org.eclipse.osgi.storage.Storage.<init>(Storage.java:124)

at org.eclipse.osgi.storage.Storage.createStorage(Storage.java:84)

at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:75)

... 11 more

before this started happening, I did attempt to load a project using SAP example PublisherExample.java when studio was not running, but I think the server was still running (? it had previously been running to start studio). I believe that attempt failed.

I have not changed anything relating to studio, or eclipse. I have just been editing and compiling .java code to run in their own processes. I had been able to publish and subscribe to/from SdkExample project previously. Now nothing works, not even studio. Please assist.