Skip to Content
avatar image
Former Member

Error Connecting to ABAP Repository from webIDE

Hi All,

When i try to import a project from ABAP Repository, it is throwing error

Cannot select the system. Check the configuration for ABAP Development Tools.


I referred this blog.

scn.sap.com/thread/3732614


All my services are activated and added in Cloud Connector. But still i am getting this error.


“/sap/opu/odata”, “/sap/bc/adt” and “/sap/bc/ui5_ui5”.


We are having GW System and ABAP System in separate boxes. And we have configured only GW Server in HCP Destination


But When i create a project from template - i can connect to GW System - get the odata services - and create and run an app. But cannot connect to ABAP Repository.


1. Should ABAP Server be configured in Destination?

2. Is it because of which i am getting the above error?



Please help.



Thanks,

Divya

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • May 27, 2015 at 01:52 PM

    Hi Divya,

    This error appears because we send a request for /sap/bc/adt/discovery and when we explore the xml we found something is missing.

    Can you please execute this call in your system that you configured in Web IDE and attach the discovery.xml?

    Thanks,
    Michal.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Michal Keidar

      I was getting exactly this error and was trying to find a way out.

      When i tried your method it showed me that i had no access to Auth_Obj S_ADT_RES

      for /sap/bc/adt/discovery.xml

      Security gave me that auth obj. and then i was able to see everything fine.

      Thanks a lot for the hint.

  • avatar image
    Former Member
    Oct 21, 2015 at 09:24 PM

    Hi Divya,

    Did you find a solution for this issue? , Please can you post the solution if it is resolved.

    I am facing similar issue when I try to connect sapWebIDE to on premise ABAP system via cloud connector.

    Thanks

    Krish

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Michal Keidar

      Hi Michal!

      My issue is resolved when i change the file name to some of my system connection name.


      Thanks very much for your help!


      Best Regards,

      Alex Ferreira.

  • avatar image
    Former Member
    Feb 04, 2016 at 11:49 AM

    Hi,

    we had the same connection issue. Try this:

    Transaction SICF -> F8 -> activate Service /default_host/sap/bc/adt

    Best Regards

    Robert

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      This works and also after doing this setting, T will ask for authentication to some different client .

      in order to point this to desired client we need to add one more line in Connection Destination file as

      sap-client=100

      where 100 is the client name

  • avatar image
    Former Member
    Sep 26, 2016 at 04:07 PM

    Hi,

    I have the problem as well. I have ensure that security was properly done for object S_ADT_RES, when I try to access <host>:<port>/sap/bc/adt/discovery it is working and I get the XML file. Unfortunately, when I try from The local SAP WebIDE I get this error. I have attached the destination file for your reference. Also, I put the picture of Google developer tool code check and you can see the error. Do you have any idea why it is not working?

    Thank you in advance for your help.


    Add comment
    10|10000 characters needed characters exceeded